Bug 696 - mouse doesn\'t work properly in xterm
: mouse doesn\'t work properly in xterm
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/emacs22-nox)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-03-08 21:05 by
Modified: 2007-02-19 15:26 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-03-08 21:05:34
Moving the current position to another place by clicking with the mouse in
xterm (emacs-nox is running there) doesn\'t work. Instead, it beeps. Indeed,
emacs moves the position to the desired place, but then immediately beeps and
jumps back to the old position. (xterm mouse support is brought to Emacs by
xt-mouse-mode turned on in /etc/emacs/site-start.d/mouse.el.)

emacs-21.1 -nw behaves properly. (Even with unset DISPLAY env variable.)

---

---
------- Comment #1 From 2004-04-29 12:33:59 -------
переназначено 
 
------- Comment #2 From 2005-11-20 23:00:50 -------
*** Bug 1152 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-11-22 23:12:30 -------
Этот баг воспроизводится и с emacs22
------- Comment #4 From 2006-04-27 16:11:39 -------
На emacs22 тоже?
------- Comment #5 From 2006-04-27 16:12:06 -------
(а это его баг тогда?)
------- Comment #6 From 2006-04-27 22:42:10 -------
(In reply to comment #4)
> На emacs22 тоже?

Да, emacs22, собранный без поддержки X, как и предыдущие версии не умеет
работать с мышкой в xterm. Это, видимо, генетическое.
------- Comment #7 From 2006-12-18 14:20:25 -------
Этот баг тоже закрываю вслед за #885:

Emacs-nox is *NOT* intended to run in an rxvt window.
use any other 'emacs -nw' instead.

Emacs-nox is a special sysadmin's build of emacs, not linked with X11 libs,
for X11-less system.

On usual system, please do not install emacs-nox.
just run 'emacs -nw'