Bug 7367 - firefox 1.0.5 doesn't handle files using external programs (pdf)
: firefox 1.0.5 doesn't handle files using external programs (pdf)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firefox)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-07-14 22:20 by
Modified: 2007-03-14 20:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-14 22:20:48
firefox-1.0.5-alt1.cvs

After the installation of new firefox, handling files with special types (say,
pdf) does not work any more -- on the second invokation of firefox by a user.

There is no reaction if a link to such a file is clicked or if it is typed into
the URL field.

Steps to Reproduce:
0. (remove firefox and firfox personal configuration for a clean experiment)
1. apt-get install firefox
2. firefox a.pdf
3. firefox a.pdf
Actual Results:  
2. the first time it suggests to open a.pdf with xpdf or save it.
3. the second time -- no reaction.

Expected Results:  
it should suggest to call an external program or save it to disk. But no menu
appears.
------- Comment #1 From 2005-07-17 07:18:35 -------
This is firefox bug 298478 and it affects more than just pdf downloads. I can
confirm that the bug is fixed in the 20050711 firefox build. 
https://bugzilla.mozilla.org/show_bug.cgi?id=298478
------- Comment #2 From 2005-07-17 07:37:38 -------
Looks like firefox-1.0.5-alt2.cvs includes the fix for mozilla/firefox bug
298478.
------- Comment #3 From 2005-07-30 11:51:25 -------
firefox-1.0.5-alt2.cvs works fine.