Bug 753 - sh: backspace broken in the single user mode
: sh: backspace broken in the single user mode
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/initscripts)
: unstable
: all Linux
: P5 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-03-26 09:28 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-03-26 09:28:32
Do a \"telinit 1\", then try to enter things in the shell prompt,
then try to delete with backspace. Ctrl-H seems to do erase the previous
symbol, but it\'s getting echoed itself.
In the ordinary root/user environment, backspace works in sh.

---

---
------- Comment #1 From 2002-03-26 14:19:56 -------
/bin/sh have been built without readline support.
Single mode should run /bin/bash instead of /bin/sh.
------- Comment #2 From 2002-03-26 14:19:56 -------
/bin/sh have been built without readline support.
Single mode should run /bin/bash instead of /bin/sh.
------- Comment #3 From 2002-03-27 01:03:37 -------
The issue is that /bin/sh gets strange keybindings or keycodes in the single
user mode. In a user profile, /bin/sh handles backspace properly.
------- Comment #4 From 2002-03-27 01:03:37 -------
The issue is that /bin/sh gets strange keybindings or keycodes in the single
user mode. In a user profile, /bin/sh handles backspace properly.
------- Comment #5 From 2002-04-15 21:00:35 -------
Fixed in
5.49-ipl40mdk
------- Comment #6 From 2002-04-15 21:00:35 -------
Fixed in
5.49-ipl40mdk
------- Comment #7 From 2002-04-16 01:23:03 -------
OK, the default shell is now bash, but the terminal echo is still broken in sh.
------- Comment #8 From 2002-04-16 01:23:03 -------
OK, the default shell is now bash, but the terminal echo is still broken in sh.
------- Comment #9 From 2002-04-16 12:23:54 -------
Yes, /bin/sh have been built without readline and termcap/terminfo support.
------- Comment #10 From 2002-04-16 12:23:54 -------
Yes, /bin/sh have been built without readline and termcap/terminfo support.