Bug 812 - twm is launched after the default WM
: twm is launched after the default WM
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xinitrc)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-04-10 12:14 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-04-10 12:14:48
After the main WM session is finished, twm is launched with an xterm window. I
believe, the problem is in the following lines in /etc/X11/Xsession:

        # Try default from runwm.
        /usr/X11R6/bin/runwm default

        # The system is broken...
        /usr/X11R6/bin/runwm failsafe

Two suggestions:
1) examine the return code of the \"runwm default\" command
2) replace runwm with a script that will detect a WM and return a command on
standard output instead of running it.
This way, Xsession can exec the command.
---

---
xinitrc-2.4.6-alt1
------- Comment #1 From 2002-04-10 18:31:39 -------
Fixed in
xinitrc-2.4.7-alt1
------- Comment #2 From 2002-04-10 18:31:39 -------
Fixed in
xinitrc-2.4.7-alt1