Bug 8155 - autoconf-2.5 don't recognize macro AC_MSG_ERROR in ntfsprogs configure.ac
: autoconf-2.5 don't recognize macro AC_MSG_ERROR in ntfsprogs configure.ac
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/autoconf_2.5)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-10-06 17:40 by
Modified: 2005-10-07 23:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-10-06 17:40:53
Autoconf failed to generate scripts for ntfsprogs

[yura@pc299 ntfsprogs-build]$ ./autogen.sh
Running autoreconf --verbose --install
autoreconf-default: Entering directory `.'
autoreconf-default: configure.ac: not using Gettext
autoreconf-default: running: aclocal --force
autoreconf-default: configure.ac: tracing
autoreconf-default: running: libtoolize --copy --force
autoreconf-default: running: /usr/bin/autoconf-2.5 --force
configure.ac:147: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:149: error: possibly undefined macro: AC_MSG_WARN
autoreconf-default: /usr/bin/autoconf-2.5 failed with exit status: 1
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

Running ./configure ...
configure: error: cannot find install-sh or install.sh in . ./.. ./../..

[yura@pc299 ntfsprogs-build]$ automake --version
automake (GNU automake) 1.9.5
[...]

[yura@pc299 ntfsprogs-build]$ autoconf --version
autoconf (GNU Autoconf) 2.59
[..]
Steps to Reproduce:
1. download ntfsprogs sources
2. run autogen.sh from package root source

Actual Results:  
error:
configure.ac:147: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.


Expected Results:  
generated confugure files
------- Comment #1 From 2005-10-06 18:50:57 -------
AC_MSG_ERROR works for me, so it looks like ntfsprogs-specific issue, probably
quotation error in its configure.ac file.
------- Comment #2 From 2005-10-06 19:06:59 -------
Not reproducible with ntfsprogs 1.11.2 and autoconf_2.5-2.59-alt4.
Btw, configure.ac:147 doesn't contain any macros.
------- Comment #3 From 2005-10-07 16:14:46 -------
Autoconf reports about error and warning in lines 137 and 139 respectively with
ntfsprogs 1.11.2.

It seems that meesage from autoconf is incorrect, in fact problem was in missing
pkg-config package. autoconf started work properly after I had installed it.

Sorry for noise.
------- Comment #4 From 2005-10-07 16:23:47 -------
autoconf is not aware of pkg-config.
------- Comment #5 From 2005-10-07 19:20:15 -------
configire.ac from ntfsprogs use PKG_CHECK_MODULES, thus generation depends on
pkg-config
------- Comment #6 From 2005-10-07 21:06:57 -------
(In reply to comment #5)
> configire.ac from ntfsprogs use PKG_CHECK_MODULES, thus generation depends on
> pkg-config
I don't understand your problem.
ntfsprogs compiles normally without calling autoreconf or autogen.sh.
------- Comment #7 From 2005-10-07 23:46:47 -------
No problem at present. I just said that autoconf message is obfuscating after I
had discovered where real problem was.