Bug 839 - graphical interface elements are not loaded
: graphical interface elements are not loaded
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/Eterm)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-04-13 20:32 by
Modified: 2003-08-25 15:18 (History)


Attachments
0000839-eterm.trace (deleted)
2002-04-15 22:25, imz
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-04-13 20:32:24
It starts with everything in plain text (the menu, no scrollbars etc.) and
prints a lot of error messages.
---
[<a href="mailto:ivan@arrakis" target="_new">ivan@arrakis</a> DATA]$ echo
$DISPLAY
:0.0
[<a href="mailto:ivan@arrakis" target="_new">ivan@arrakis</a> DATA]$ Eterm
Eterm:  Error:  Unable to load image file \&quot;tile/twisted.jpg\&quot;
Eterm:  Error:  Unable to locate image \&quot;tile/twisted.jpg\&quot; in the
image path.
Eterm:  Error:  Unable to load image file \&quot;bar_vertical_3.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_vertical_3.png\&quot; in the
image path.
Eterm:  Error:  Unable to load image file \&quot;bar_vertical_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_vertical_1.png\&quot; in the
image path.
Eterm:  Error:  Unable to load image file \&quot;bar_vertical_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_vertical_2.png\&quot; in the
image path.
Eterm:  Error:  Unable to load image file \&quot;thumb_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;thumb_1.png\&quot; in the image
path.
Eterm:  Error:  Unable to load image file \&quot;thumb_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;thumb_2.png\&quot; in the image
path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_up_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_up_1.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_up_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_up_2.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_up_3.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_up_3.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_down_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_down_1.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_down_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_down_2.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;button_arrow_down_3.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;button_arrow_down_3.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_1.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_2.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;menu1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;menu1.png\&quot; in the image
path.
Eterm:  Error:  Unable to load image file \&quot;menu2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;menu2.png\&quot; in the image
path.
Eterm:  Error:  Unable to load image file \&quot;menu3.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;menu3.png\&quot; in the image
path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_1.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_1.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_1.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_2.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_2.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;bar_horizontal_3.png\&quot;
Eterm:  Error:  Unable to locate image \&quot;bar_horizontal_3.png\&quot; in
the image path.
Eterm:  Error:  Unable to load image file \&quot;help.png\&quot;
Eterm:  Error:  Unable to load image file \&quot;exit.png\&quot;
$ 
---
------- Comment #1 From 2002-04-13 20:40:15 -------
I was wrong: the scrollbar is there, but still the terminal looks much uglier
than before. There is no horizontal bar, no background image.
------- Comment #2 From 2002-04-13 20:40:15 -------
I was wrong: the scrollbar is there, but still the terminal looks much uglier
than before. There is no horizontal bar, no background image.
------- Comment #3 From 2002-04-15 12:14:39 -------
This bug is not reproducable. All graphical interface elements are loaded
properly. There are nice backgrounds, scrollbar, buttonbar, popup menu.
Check your Eterm installation and configs.
Eterm-0.9.1-alt1.1
------- Comment #4 From 2002-04-15 12:14:39 -------
This bug is not reproducable. All graphical interface elements are loaded
properly. There are nice backgrounds, scrollbar, buttonbar, popup menu.
Check your Eterm installation and configs.
Eterm-0.9.1-alt1.1
------- Comment #5 From 2002-04-15 22:30:18 -------
the trace log attached shows what the problem is (obtained by strace -e
trace=file -o eterm.trace Eterm). Look at this line:

open(\&quot;/usr/lib/imlib2/loaders/image/xpm\&quot;, O_RDONLY) = -1 ENOENT (No
such file or directory)
open(\&quot;/usr/lib/imlib2/loaders/image/xpm.la\&quot;, O_RDONLY) = -1 ENOENT
(No such file or directory)

It tries to use the .la-files. They are not part of the imlib2 package, they
are provided by imlib2-devel:

$ rpm -qf /usr/lib/imlib2/loaders/image/xpm.la 
imlib2-devel-1.0.5-alt1
$ 

(And indeed, after installing imlib2-devel Eterm is again nice.)

Perhaps, this is a bug of libtool, or of the build and packaging procedure.
------- Comment #6 From 2002-04-15 22:30:18 -------
the trace log attached shows what the problem is (obtained by strace -e
trace=file -o eterm.trace Eterm). Look at this line:

open(\&quot;/usr/lib/imlib2/loaders/image/xpm\&quot;, O_RDONLY) = -1 ENOENT (No
such file or directory)
open(\&quot;/usr/lib/imlib2/loaders/image/xpm.la\&quot;, O_RDONLY) = -1 ENOENT
(No such file or directory)

It tries to use the .la-files. They are not part of the imlib2 package, they
are provided by imlib2-devel:

$ rpm -qf /usr/lib/imlib2/loaders/image/xpm.la 
imlib2-devel-1.0.5-alt1
$ 

(And indeed, after installing imlib2-devel Eterm is again nice.)

Perhaps, this is a bug of libtool, or of the build and packaging procedure.
------- Comment #7 From 2002-04-16 04:30:45 -------
Thanks. Problem fixed in the imlib2-1.0.5-alt2 package. Please test it.
------- Comment #8 From 2002-04-16 04:30:45 -------
Thanks. Problem fixed in the imlib2-1.0.5-alt2 package. Please test it.
------- Comment #9 From 2002-04-17 22:27:12 -------
It works fine. (Eterm-0.9.1 is great!) I would close the bug, if it was
resloved.
------- Comment #10 From 2002-04-17 22:27:12 -------
It works fine. (Eterm-0.9.1 is great!) I would close the bug, if it was
resloved.