Bug 909 - update-alternative improperly handles slave links in certain conditions
: update-alternative improperly handles slave links in certain conditions
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/update-alternatives)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-05-10 19:13 by
Modified: 2005-10-20 15:23 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-05-10 19:13:35
As I described in <a
href="http://www.altlinux.ru/pipermail/sisyphus/2002-May/010817.html">http://www.altlinux.ru/pipermail/sisyphus/2002-May/010817.html</a>, 
update-alternatives looses slave autom4te link for autoconf_2.5 package.
Probably this happens because autoconf_2.13 which acts as another (and primary)
alternative for autoconf doesn\'t contain autom4te at all...
---

---
Well, probably the simplest solution is to make autom4te the \'real\' link not
a slave alternative. But this doesn\'t solve the problem only its symptoms
------- Comment #1 From 2003-09-06 22:55:57 -------
This bug doesn't apply to new alternatives(8), does it? 
------- Comment #2 From 2005-10-20 14:14:14 -------
так может прикрыть эту багу?
------- Comment #3 From 2005-10-20 15:23:07 -------
Нет смысла исправлять этот старый пакет.