Bug 917 - Is mod_perl compiled with Apache::Table?
: Is mod_perl compiled with Apache::Table?
Status: CLOSED DUPLICATE of bug 2373
: Sisyphus
(All bugs in Sisyphus/apache-mod_perl)
: unstable
: all Linux
: P4 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-05-13 19:13 by
Modified: 2003-11-02 23:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-05-13 19:13:34
Seems that mod_perl _lacks_ Apache::Table (isn\'t built with EVERYTHING=1, or
at minimum PERL_TABLE_API=1).
---

---
The problem manifests itself during \"perl -MCPAN -e\'install
Apache::Cookie\'\" (which would be best found in Sisyphus ;).

Citing <a
href="http://www.apache.org/dist/httpd/libapreq-1.0.readme">http://www.apache.org/dist/httpd/libapreq-1.0.readme</a>
:

IMPORTANT NOTE: To install the Perl modules, your mod_perl installation
MUST includes support for Apache::Table.  This means that mod_perl should
be built using the EVERYTHING=1, or at minimum PERL_TABLE_API=1.  If you
see errors like this (during compilation of libapreq)

        Error: \'Apache::Table\' not in typemap in Request.xs,

your mod_perl must be rebuilt to include Apache::Table support.
------- Comment #1 From 2003-08-30 14:43:15 -------
going to fix it along #2373 proposal while building 1.3.28 with pilot@

*** This bug has been marked as a duplicate of 2373 ***