Bug 9229 - Не хватает зависимости на libgtk+2-devel
: Не хватает зависимости на libgtk+2-devel
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libgtkspell-devel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-03-11 15:54 by
Modified: 2006-09-28 20:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-11 15:54:10
libgtkspell-devel должен зависеть от libgtk+2-devel, потому что gtkspell-2.0.pc
требует файл gtk+-2.0.pc.

Чревато это тем, что в хашере pkg-config возвращает не верную информацию:

[builder@rock poedit-1.3.4]$ pkg-config --exists "libgtkspell-2.0"; echo rc=$?
rc=1

В то время, как:

[builder@rock poedit-1.3.4]$ pkg-config --list-all | grep spell
gtkspell-2.0          GTKSpell - GTK spelling library
------- Comment #1 From 2006-03-11 15:59:54 -------
На самом деле при очередной сборке пакет получит необходимые зависимости
посредством pkgconfig(...).
------- Comment #2 From 2006-03-13 12:04:44 -------
(In reply to comment #1)
> На самом деле при очередной сборке пакет получит необходимые зависимости
> посредством pkgconfig(...).

Разве для этого не делалась автоматическая пересборка?
------- Comment #3 From 2006-05-11 17:04:00 -------
хоть при очередной сборке пакет получит необходимые зависимости
посредством pkgconfig, я всёже добавил их руками в alt6.