Bug 965 - /etc/X11/xdm/Xresources sets *Foreground and *Background
: /etc/X11/xdm/Xresources sets *Foreground and *Background
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xinitrc)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-05-30 15:03 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-05-30 15:03:40
In xinitrc-2.4.7-alt1 /etc/X11/xdm/Xresources contains:

*Foreground: black
*Background: #fffff0

These resources are left in the resource database after login and affect all user applications (especially highlighted buttons in Tcl/Tk apps look very strange). This effect is also visible with kdm.

Probably setting xlogin*Foreground and xlogin*Background was intended instead. Also, completely resetting the resource database in /etc/X11/Xsession before merging the resource files may be useful.
---

---

------- Comment #1 From 2002-11-11 15:55:02 -------
Should be fixed in 2.4.8-alt1; please reopen if not.
------- Comment #2 From 2002-11-11 15:55:02 -------
Should be fixed in 2.4.8-alt1; please reopen if not.
------- Comment #3 From 2002-11-14 22:56:51 -------
OK (cleaning still not performed, but at least these resources don\'t affect
normal applications).
------- Comment #4 From 2002-11-14 22:56:51 -------
OK (cleaning still not performed, but at least these resources don\'t affect
normal applications).