Bug 9672 - system full freeze during the changing bcm4401 MAC address
: system full freeze during the changing bcm4401 MAC address
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std26-up)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: http://lists.altlinux.org/pipermail/s...
:
:
:
  Show dependency tree
 
Reported: 2006-06-05 01:10 by
Modified: 2006-06-25 17:06 (History)


Attachments
b44 (broadcom ethernet) set MAC bugfix (420 bytes, patch)
2006-06-05 01:11, Artem Delendik
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-05 01:10:27
It reproduced in 2.6.14 kernel - I haven't newer kernel on me, but it seems that
this bug still open in later kernels.
System completely freeses whilst changing Broadcom bcm4401 MAC address (b44
module) in case the card haven't "upped" by ifconfig at least one time before.
It's because of the bcm4401's MAC and PCI hardware blocks haven't powered yet
after module inserting. 
Steps to Reproduce:
1.boot the system, login as root, modprobe b44 (if not loaded yet)
2.ifconfig ethX hw ether 01:02:03:04:05:06:07
3.freeeeeze! Press power button to reboot :-)
------- Comment #1 From 2006-06-05 01:11:49 -------
Created an attachment (id=1512) [details]
b44 (broadcom ethernet) set MAC bugfix
------- Comment #2 From 2006-06-25 17:06:36 -------
Fixed in kernel-image-std26-*-2.6.16-alt7.