Bug 22309

Summary: versionize symbols
Product: [Development] Sisyphus Reporter: Ivan Zakharyaschev <imz@altlinux.org>
Component: libfribidiAssignee: Yuri N. Sedunov <aris@altlinux.org>
Status: CLOSED DUPLICATE QA Contact: qa-sisyphus@altlinux.org
Severity: normal    
Priority: P3 CC: mike@altlinux.org, rider@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   
Bug Depends on:    
Bug Blocks: 22308    

Description From 2009-11-17 00:32:26
libfribidi-0.10.9-alt2

The symbols should be versionized in the library: so that programs built with
newer versions of the library would formally require the new version of the
library; a case of a problem:
https://bugzilla.altlinux.org/show_bug.cgi?id=22308 .

http://www.altlinux.org/Shared_Library_Symbol_Versioning_HOWTO#.D0.9A.D0.B0.D0.BA_.D1.83.D0.B7.D0.BD.D0.B0.D1.82.D1.8C.2C_.D1.83.D0.B1.D0.B0.D0.B2.D0.B8.D0.BB.D0.B8.D1.81.D1.8C_.D0.BB.D0.B8_.D0.B8.D0.BB.D0.B8_.D0.B4.D0.BE.D0.B1.D0.B0.D0.B2.D0.B8.D0.BB.D0.B8.D1.81.D1.8C_.D0.BD.D0.BE.D0.B2.D1.8B.D0.B5_.D1.81.D0.B8.D0.BC.D0.B2.D0.BE.D0.BB.D1.8B_.D0.B8_.D0.BA.D0.B0.D0.BA_.D1.81.D0.B4.D0.B5.D0.BB.D0.B0.D1.82.D1.8C_version_script
------- Comment #1 From 2009-11-17 09:42:26 -------
я не могу сопровождать этот пакет.
------- Comment #2 From 2010-09-26 14:12:52 -------
Насколько понимаю, эквивалент будет сделан автоматически при следующей
пересборке (с генерацией set provides).
------- Comment #3 From 2010-09-26 14:15:38 -------

*** This bug has been marked as a duplicate of bug 22308 ***