Bug 29688

Summary: guess-kbd: команда не найдена
Product: [Development] Sisyphus Reporter: aebirukov@gmail.com
Component: make-initrd-luksAssignee: Alexey Gladkov <legion@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: normal    
Priority: P3 CC: aebirukov@gmail.com, aen@altlinux.org, boyarsh@altlinux.org, cas@altlinux.org, mike@altlinux.org, rider@altlinux.org, sem@altlinux.org, vseleznv@cs.msu.ru, zerg@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   
Bug Depends on:    
Bug Blocks: 30940    

Description From 2014-01-08 15:22:56
При попытке сгенерировать образ:

Generating module dependencies on host ...
/usr/share/make-initrd/features/luks/guess/device: line 13: guess-kbd: команда
не найдена
------- Comment #1 From 2014-01-08 22:15:59 -------
Да, такого скрипта в сизифе больше нет (исправлять сперва надо там).  Убран он
был коммитом 5ce651f56e41482565af3495b68654064cdb513f в make-initrd.git,
остался там же в одном месте.

2 legion: смотрю на features/luks/guess/device и guess/keyboard/rules.mk -- и
guess-kbd, и guess-functions keyboard объявлены устаревшими, а как
задействовать guess/keyboard/ тогда?
------- Comment #2 From 2016-05-30 14:20:24 -------
*** Bug 32144 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2016-06-17 14:32:28 -------
http://git.altlinux.org/people/legion/packages/make-initrd.git?p=make-initrd.git;a=commitdiff;h=a5153a4b3261f7dfe3738da2f6f723f1fdfe2d29
------- Comment #4 From 2016-06-27 14:53:43 -------
make-initrd2-2.0.1-alt1 -> sisyphus:

* Mon Jun 27 2016 Alexey Gladkov <legion@altlinux> 2.0.1-alt1
- Add initrd-ls.
- Add ucode feature for early loading microcode.
- Add libnss_* only for target arch (closes: #32180).
- Add documentation (closes: #28967).
- Remove obsolete guess-kbd (closes: #29688).
- Fix compress detection for complex images.