Bug 32144 - Cannot build initrd when luks is enabled
: Cannot build initrd when luks is enabled
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/make-initrd2-luks)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-05-26 20:25 by
Modified: 2017-07-15 20:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-05-26 20:25:03
Невозможно собрать initrd с включенной feature luks:

Config file: /etc/initrd.mk
Generating module dependencies on host ...
/usr/share/make-initrd/features/luks/guess/device: line 13: guess-kbd: command
not found
make: *** [guess-resume] Error 127
make: *** [all] Error 1
------- Comment #1 From 2016-05-30 14:20:24 -------
Давайте дождёмся ответа legion@ в уже повешенной баге,
но у меня, как ни странно, такие initrd формируются (/ на luks).

*** This bug has been marked as a duplicate of bug 29688 ***
------- Comment #2 From 2016-05-30 14:21:23 -------
Как вариант, можно перевесить этот баг на make-initrd2-luks, если там так же.
:)
------- Comment #3 From 2016-06-07 23:49:39 -------
В make-initrd2 проблема воспроизводится.
------- Comment #4 From 2017-07-15 20:21:04 -------
Решена в коммите a5153a4 [1].

[1]
http://git.altlinux.org/gears/m/make-initrd.git?p=make-initrd.git;a=commit;h=a5153a4b3261f7dfe3738da2f6f723f1fdfe2d29