Bug 8791

Summary: old libglib required
Product: [Development] Sisyphus Reporter: Michael Shigorin <mike@altlinux.org>
Component: pam0_consoleAssignee: Dmitry V. Levin <ldv@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: minor    
Priority: P2 CC: icesik@altlinux.org, zerg@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   

Description From 2006-01-03 19:13:03
libglib-1.2.so.0   is needed by pam0_console-0.75-alt28

is it perfectly ok? :)
------- Comment #1 From 2006-01-03 21:06:54 -------
Yes, old glib is OK for pam_console.
------- Comment #2 From 2006-01-03 23:30:10 -------
А давайте она будет хорошо себя чувствовать с glib2? 
------- Comment #3 From 2006-01-03 23:53:11 -------
Я не хочу, glib меня пока что устраивает.
------- Comment #4 From 2006-01-04 18:12:28 -------
*sigh*.  Пока что == LATER? :)

(чистили тут один корешок, обнаружили, что старый glib нужен одному, но важному,
клиенту)
------- Comment #5 From 2006-01-04 19:07:07 -------
Дело в том, что та часть glib, которая нужна для pam_console, а именно работа
со
списками, не вызывает претензий.  Тащить в базовую серверную систему более
толстый glib2 я не тороплюсь.  Раздумываю над тем, чтобы вынести pam_console в
совсем отдельный пакет и убрать c него зависимости из login.
Ибо на сервере pam_console лишний.
------- Comment #6 From 2006-01-04 19:27:11 -------
Тоже да.  Может, так багу и перекрасим?
------- Comment #7 From 2006-02-17 19:59:09 -------
Для 3.1 было бы даже хорошо?
------- Comment #8 From 2006-03-11 20:23:47 -------
А ещё я слышал что у glib2 ABI нестабильный.
------- Comment #9 From 2006-03-11 21:32:05 -------
Вроде стабильный, за последние полгода старое точно не ломали.
------- Comment #10 From 2006-03-12 14:33:57 -------
(In reply to comment #0) 
> libglib-1.2.so.0   is needed by pam0_console-0.75-alt28 
> is it perfectly ok? :) 
А что в этом плохого? Зачем вообще там glib2? Он что, красивее писать будет на 
экране? 
IMHO если мантейнера устраивает, то и дергаться нет смысла. 
Другое дело, если приложение графическое и использующее gtk, тогда gtk-2 
конечно предпочтительнее для красоты и удобства. 
------- Comment #11 From 2006-04-27 15:24:00 -------
(In reply to comment #10)
> > libglib-1.2.so.0   is needed by pam0_console-0.75-alt28 
> > is it perfectly ok? :) 
> А что в этом плохого?
Ещё одна библиотека, которая используется ровно одним пакетом на системе.
Зачищал образ под, кажется, vserver -- вот и развешивал такие баги.
------- Comment #12 From 2007-04-05 16:00:28 -------
Ну этот перфекционизм.  Работает -- не трогай, а про pam_console всё равно при
зачистке VE ещё будем вспоминать.
------- Comment #13 From 2008-02-18 19:10:29 -------
changing resolution
------- Comment #14 From 2008-02-18 19:13:02 -------
Starting with 0.99.4.0 pam_console does not use glib* at all.
0.99.10.0-alt1 is going to be released without glib* reqs.
------- Comment #15 From 2008-02-18 20:25:29 -------
ack