Bug 10065 - gamma resetting in kdm
: gamma resetting in kdm
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/kdebase-kdm)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-01 13:24 by
Modified: 2007-06-22 14:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-01 13:24:09
Существует следующая проблема: устанавливаем в конфиге xorg.conf параметр Gamma
для монитора в какое-то значение >1, например 1.8, загружаются иксы: видно, что
параметр работает - светло. Дальше загружается kdm, все нормально, светло.
Дальше выбираем некую сессию (не важно какую - проверял и на KDE, и на
ratpoison
/ fluxbox), логинимся, в момент передачи управления дальше window manager'у
гамма сбрасывается на 1 (видно, что все темнеет). Загрузившись, восстанавливаем
значение gamma обратно на 1.8 с помощью утилиты xgamma, наблюдаем такую
картину:

$ xgamma -gamma 1.8
-> Red  1.800, Green  1.800, Blue  1.800
<- Red  1.800, Green  1.800, Blue  1.800

При этом экран действительно светлеет, но иксы до этого честно верили,
что гамма и была 1.8, хотя в действительности она сброшена на 1.

Момент сброса - переход из kdm к сессии. Такого не происходит, если не
пользоваться dm'ами вообще (т.е. запускать от юзера из консоли startx), или
если
использовать другой dm (опробовано на xdm).

На всякий случай, карточка - NVIDIA GF 6600 GT, монитор - CRT. Драйвер -
nvidia.
------- Comment #1 From 2006-10-03 14:29:06 -------
А в другом xDM проявляется?
------- Comment #2 From 2006-10-03 14:30:07 -------
Если установлен пакет nvidia-settings, есть ли файл ~/.nvidia-settings-rc ?
------- Comment #3 From 2006-10-03 15:21:44 -------
В xdm не проявляется. На ~/.nvidia-settings-rc посмотрю вечером, но вообще
говоря - то же самое видно под свежим юзером, у которого вряд ли сразу есть
~/.nvidia-setting-rc.
------- Comment #4 From 2007-06-21 16:31:52 -------
не воспроизводится

$ rpm -q kdebase-kdm
kdebase-kdm-3.5.7-alt5
Карточка: GeForce 6150
драйвер: kernel-modules-nvidia-std-smp-100.14.09-alt1.132626.6
2.6.18-std-smp-alt6
x86_64
------- Comment #5 From 2007-06-22 10:00:49 -------
У меня тоже это негде теперь воспроизводить - сейчас несколько другая
конфигурация. Будем считать локальным misconfiguration и закроем как INVALID /
WORKSFORME / WONTFIX?
------- Comment #6 From 2007-06-22 14:59:39 -------
давайте