Bug 10082 - Crash
: Crash
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/aMule)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-03 17:31 by
Modified: 2007-08-01 23:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-03 17:31:26
Падает при закрытии табов с результатами поиска. Стоит Sisiphus с последними
версиями программ. В файле .xsession-errors:0 есть такая информация:

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS:
|=----------------------------
Current version is: aMule 2.1.2 using wxGTK2 v2.6.3 (Unicoded)
Running on: Linux 2.6.16-std26-smp-alt9 i686

[2] wxObject::ReservedObjectFunc9() in amule [0x8073caf]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0xb7ba65ee]
[4] ?? in /lib/libpthread.so.0 [0xb798b0ac]
[5] ?? in [0xffffe420]
[6] __dynamic_cast in /usr/lib/libstdc++.so.6[0xb7aab1ad]
[7] wxSpinEvent::~wxSpinEvent() in amule [0x8191e7c]
[8] wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&),
wxEvent&) const in /usr/lib/libwx_baseu-2.6.so.0[0xb7b15c71]
[9] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&,
wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.6.so.0[0xb7ba0bca]
[10] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in
/usr/lib/libwx_baseu-2.6.so.0[0xb7ba0e66]
[11] wxEvtHandler::ProcessEvent(wxEvent&) in
/usr/lib/libwx_baseu-2.6.so.0[0xb7ba1957]
[12] wxWindowBase::TryParent(wxEvent&) in
/usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7e231b5]
[13] wxEvtHandler::ProcessEvent(wxEvent&) in
/usr/lib/libwx_baseu-2.6.so.0[0xb7ba190c]
[14] ?? in /usr/lib/libwx_gtk2u_core-2.6.so.0 [0xb7d963fa]
[15] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb761a0fd]
[16] g_closure_invoke in /usr/lib/libgobject-2.0.so.0[0xb740171f]
[17] ?? in /usr/lib/libgobject-2.0.so.0 [0xb74109c4]
[18] g_signal_emit_valist in /usr/lib/libgobject-2.0.so.0[0xb7411ee8]
[19] g_signal_emit in /usr/lib/libgobject-2.0.so.0[0xb74120a1]
[20] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb763bdc8]
[21] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb763c061]
[22] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb763522c]
[23] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb7616a79]
[24] ?? in /usr/lib/libgobject-2.0.so.0 [0xb73fffc5]
[25] g_closure_invoke in /usr/lib/libgobject-2.0.so.0[0xb740171f]
[26] ?? in /usr/lib/libgobject-2.0.so.0 [0xb7411001]
[27] g_signal_emit_valist in /usr/lib/libgobject-2.0.so.0[0xb7411cb1]
[28] g_signal_emit in /usr/lib/libgobject-2.0.so.0[0xb74120a1]
[29] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0xb7768063]
[30] gtk_widget_event in /usr/lib/libgtk-x11-2.0.so.0[0xb7767bea]
[31] gtk_propagate_event in /usr/lib/libgtk-x11-2.0.so.0[0xb761515a]
[32] gtk_main_do_event in /usr/lib/libgtk-x11-2.0.so.0[0xb7613cfe]
[33] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb747ab38]
[34] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb7393e88]
[35] ?? in /usr/lib/libglib-2.0.so.0 [0xb7396c22]
[36] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb7396fcc]
[37] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb76133ba]
[38] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7d29054]
[39] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7daebb6]
[40] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7daecda]
[41] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0xb7b4ab2a]
[42] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0xb7b4abf4]
[43] wxWindowBase::SetName(wxString const&) in amule [0x816f9da]
[44] __libc_start_main in /lib/libc.so.6[0xb7886531]
[45] __gxx_personality_v0 in amule[0x806bb41]


Steps to Reproduce:
1. Запускаю aMule
2. Перехожу в в поиск
3. Ввожу что-нибудь
4. Закрываю таб с результатами поиска
5. Программа закрывается
------- Comment #1 From 2007-01-05 05:04:24 -------
Это бага в wxWidgets, а не в  aMule.

В wxWidgets 2.8.0 это исправлено. Хорошо бы пересобрать с этой версией.

Кстати, вышла aMule 2.1.3 неплохо было бы обновить.
------- Comment #2 From 2007-04-04 20:47:56 -------
В Сизифе wxGTK2u всё ещё версии 2.6.3.
------- Comment #3 From 2007-04-05 14:29:58 -------
смотрите внимательнее. apt-cache show wxGTK.
------- Comment #4 From 2007-04-05 14:31:00 -------
*** Bug 11358 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2007-04-22 15:39:56 -------
Што делать с wxGTK?  Хто будет собирать 2.8 или не будет?
------- Comment #6 From 2007-04-23 09:32:05 -------
2.8 у нас уже собран, и давно.

[ agent_007:satellite:~/RPM/BUILD  0 ] $ apt-cache showpkg wxGTK | head -4     
                                                                               
                 

Package: wxGTK
Versions:
2.8.3-alt1(/var/lib/rpm/Packages)
2.8.3-alt1(/var/lib/apt/lists/ftp.altlinux.org_pub_distributions_ALTLinux_Sisyphus_x86%5f64_base_pkglist.classic)
------- Comment #7 From 2007-04-25 07:44:23 -------
А тольку? Всё равно aMule собран с wxGTK2u-2.6.3-alt2, и майнтейнер не спешит
его пересобрать с новым wxGTK.
------- Comment #8 From 2007-04-25 09:35:19 -------
и правильно. потому что:
1. собрать его с 2.8.х задача нетривиальная. я, честно говоря, вообще не знаю
дистрибутива, где amule не из cvs собран с wxGTK 2.8.х;
2. это не решает проблему с вкладками.

------- Comment #9 From 2007-04-25 09:38:47 -------
to: Alexey Tourbin

если у тебя хватает сил на wxGTK2u, собери 2.6.4, плз. я всё-таки за то, чтобы
пока оставить 2 ветки wx, хотя бы из-за того же aMule и интерфейсов к vlc.
------- Comment #10 From 2007-08-01 09:18:02 -------
поскольку at@, видимо, не имеет времени на aMule и wxGTK2u, то:
fixed in aMule-2.1.3-alt1 and wxGTK2u-2.6.4-alt1
------- Comment #11 From 2007-08-01 23:13:39 -------
Спасибо, algor!
У меня действительно не было в ближайших планах ковырять wxGTK.