Bug 1009 - Garbage in apropos output
: Garbage in apropos output
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/man)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-06-17 12:21 by
Modified: 2008-08-23 03:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-06-17 12:21:46
I run \"apropos group password\" and get a lot of garbage like this
among legitimate entries:

although # I believe that you will find pagesize=512 \'best\'. # 3) Adding
nofsync increases speed [config_macros] (3)  - %__pgp_check_password_cmd
%{__pgp} pgp +batchmode=on +verbose=0 \'%{_pgp_name}\' -sf
%__pgp5_check_password_cmd %{__pgp} pgps +batchmode=on +verbose=0 +armor=off
\'%{_pgp_name}\' -f
and fixperms are run at the end of hardcoded setup # These macros are necessary
only for legacy compatibility [config_macros] (3)  - %__pgp_check_password_cmd
%{__pgp} pgp +batchmode=on +verbose=0 \'%{_pgp_name}\' -sf
%__pgp5_check_password_cmd %{__pgp} pgps +batchmode=on +verbose=0 +armor=off
\'%{_pgp_name}\' -f
and have moved # to per-platform macro configuration (i.e.
/usr/lib/rpm/<arch>-<os>/macros) #%__id_u %{__id} -u #%__chown_Rhf
%{__chown} -Rhf #%__chgrp_Rhf %{__chgrp} -Rhf #%_fixowner [ `%{__id_u}` = \'0\'
] && %{__chown_Rhf} root #%_fixgroup [ `%{__id_u}` = \'0\' ] &&
%{__chgrp_Rhf} root #%_fixperms %{__chmod} -Rf a+rX [config_macros] (3)  -
%__pgp_check_password_cmd %{__pgp} pgp +batchmode=on +verbose=0
\'%{_pgp_name}\' -sf %__pgp5_check_password_cmd %{__pgp} pgps +batchmode=on
+verbose=0 +armor=off \'%{_pgp_name}\' -f
# and you will need ~256Kb to handle a typical machine install. # 2) Only the
Packages hash [config_macros] (3)  - %__pgp_check_password_cmd %{__pgp} pgp
+batchmode=on +verbose=0 \'%{_pgp_name}\' -sf %__pgp5_check_password_cmd
%{__pgp} pgps +batchmode=on +verbose=0 +armor=off \'%{_pgp_name}\' -f
because of the size of the values (i.e. headers) [config_macros] (3)  -
%__pgp_check_password_cmd %{__pgp} pgp +batchmode=on +verbose=0
\'%{_pgp_name}\' -sf %__pg
---

---
------- Comment #1 From 2002-06-17 16:43:54 -------
Unable to reproduce.
------- Comment #2 From 2002-06-17 16:43:54 -------
Unable to reproduce.
------- Comment #3 From 2002-12-30 00:03:19 -------
Requires librpm-devel to reproduce.
------- Comment #4 From 2002-12-30 00:03:19 -------
Requires librpm-devel to reproduce.
------- Comment #5 From 2004-05-28 17:20:08 -------
не воспроизводится даже с установленым librpm-devel.
я её делаю minor, если появится какой-то man, на котором это воспроизведётся,
тогда и будем фиксить
------- Comment #6 From 2006-12-16 20:07:16 -------
(In reply to comment #5)
> не воспроизводится даже с установленым librpm-devel.
Аналогично.  F/W/I?
------- Comment #7 From 2008-01-14 10:32:15 -------
Не воспроизводится.

man-1.5m2-alt4
librpm-devel-4.0.4-alt81

Закрываю как... WORKSFORME.