Bug 10108 - icewm segfaults on qt4 app exit
: icewm segfaults on qt4 app exit
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/icewm)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 9199
  Show dependency tree
 
Reported: 2006-10-10 16:38 by
Modified: 2006-12-15 12:44 (History)


Attachments
larger chunk (11.61 KB, application/x-bzip)
2006-10-10 16:53, Michael Shigorin
no flags Details
tail -200 (10.41 KB, text/plain)
2006-10-10 16:53, Michael Shigorin
no flags Details
Icewm not segfault with this patch on me. (327 bytes, patch)
2006-11-12 14:56, Dmitriy Khanzhin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-10 16:38:51
when quitting alterator-standalone <somemodule>, icewm segfaults and restarts

this is reproducible with e.g.:
alterator-browser-qt-light-2.6-alt35
alterator-standalone-2.5-alt0.3
alterator-net-general-0.1-alt1
icewm-1.2.25-alt3

strace -ff -p `pidof icewm` attached; setting severity as "normal" since it does
restart successfully, nothing lost ;)

2 sr: it's there, if you'll get around and look into this, would be nice
------- Comment #1 From 2006-10-10 16:53:35 -------
Created an attachment (id=1660) [details]
larger chunk
------- Comment #2 From 2006-10-10 16:53:59 -------
Created an attachment (id=1661) [details]
tail -200
------- Comment #3 From 2006-10-16 17:35:07 -------
seems it's a problem between qt4 4.2.0 and icewm: 1.2.28 and 4.2.0 lead to
segfault, while rollback to 4.1.4 results in no segfaults with both qtbrowser
and another qt4 application here.

2 zerg: can't google "icewm qt4 sigsegv" (and like that) down, any ideas?  it
will make icewm usage problematic with both current alterator and seemingly any
qt4 apps...

2 rider: I can update icewm in Sisyphus (patch1 merged, patch10 needs minor update)
------- Comment #4 From 2006-11-12 14:56:41 -------
Created an attachment (id=1679) [details]
Icewm not segfault with this patch on me.

У меня IceWM перестал сегфолтиться с этим патчем.
Взят из апстримовского трекера
https://sourceforge.net/tracker/?func=detail&atid=100031&aid=1573405&group_id=31
------- Comment #5 From 2006-11-12 21:18:24 -------
О, замечательно.  А кто-нить добавит его в сборку 1.2.28?
------- Comment #6 From 2006-11-13 00:13:14 -------
(In reply to comment #5)
> О, замечательно.  А кто-нить добавит его в сборку 1.2.28?

2 evg@: Посмотрите патчик и добавьте, пожалуйста!
------- Comment #7 From 2006-12-02 00:18:18 -------
(In reply to comment #6)
> (In reply to comment #5)
> > О, замечательно.  А кто-нить добавит его в сборку 1.2.28?
> 2 evg@: Посмотрите патчик и добавьте, пожалуйста!

Добавил.

2 mike@: Миш, закрывай, если полегчало.
------- Comment #8 From 2006-12-04 14:51:48 -------
Подтверждаю, исправлено для 1.2.28-alt3.
Спасибо!