Bug 10120 - у last-exit не хватает зависимостей
: у last-exit не хватает зависимостей
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/last-exit)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-12 16:17 by
Modified: 2007-02-12 14:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-12 16:17:28
[icesik@iceberg ~]$ last-exit
/usr/bin/last-exit: line 5: /usr/bin/mono: Нет такого файла или каталога
/usr/bin/last-exit: line 5: exec: /usr/bin/mono: cannot execute: Нет такого
файла или каталога
[icesik@iceberg ~]$ rpm -q last-exit
last-exit-2.0-alt1
[icesik@iceberg ~]$

Думаю, его надо просто пересобрать свежим rpm'ом
------- Comment #1 From 2006-10-12 16:45:08 -------
После установки mono ...

[icesik@iceberg ~]$ last-exit

** (/usr/lib/last-exit/last-exit.exe:8421): WARNING **: The following assembly
referenced from /usr/lib/last-exit/last-exit.exe could not be loaded:
     Assembly:   gnome-sharp    (assemblyref_index=6)
     Version:    2.8.0.0
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/last-exit).


** (/usr/lib/last-exit/last-exit.exe:8421): WARNING **: Could not load file or
assembly 'gnome-sharp, Version=2.8.0.0, Culture=neutral,
PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
The entry point method could not be loaded
[icesik@iceberg ~]$
------- Comment #2 From 2006-10-12 16:56:35 -------
да 3 вышла
------- Comment #3 From 2006-10-12 18:24:14 -------
Заодно он как раз перестал собираться на Сизифе.
Сейчас починю.
------- Comment #4 From 2006-10-12 19:03:27 -------
Вру, сейчас не починю - нет под рукой Сизифа, где работал бы libgtk+2-devel.
Завтра, видимо, будет.
------- Comment #5 From 2006-11-03 20:19:50 -------
Я не тормоз, у меня просто затруднение: last-exit пользуется DllImport, а
потому
хочет разнообразных *.so, а следовательно -- devel-пакетов. Сам я таким могу
пользоваться, но выкладывать в Сизиф -- засмеют.
Я склоняюсь к тому, чтобы поставить WONTFIX и убрать last-exit в orphaned, но,
может, есть другие идеи?
------- Comment #6 From 2006-11-06 14:47:48 -------
(In reply to comment #5)
> Я не тормоз, у меня просто затруднение: last-exit пользуется DllImport, а потому
> хочет разнообразных *.so, а следовательно -- devel-пакетов. Сам я таким могу
> пользоваться, но выкладывать в Сизиф -- засмеют.
> Я склоняюсь к тому, чтобы поставить WONTFIX и убрать last-exit в orphaned, но,
> может, есть другие идеи?

Кинь в Дедал. Может мысли найдутся. ;)
------- Comment #7 From 2006-11-11 23:54:55 -------
Пока только здесь: git.alt:/people/avm/packages/last-exit.git
------- Comment #8 From 2006-12-21 17:39:35 -------
*** Bug 10474 has been marked as a duplicate of this bug. ***
------- Comment #9 From 2006-12-21 18:54:23 -------
Положил в incoming новую версию. Там при сборке DllImport(libc) переписывается
в
DllImport(libc.so.6), и так далее. Получается такой кривой линкер на sed.
У меня работает, впрочем.
Безыдейно а что делать.