Bug 10138 - Не устанавливается pdns
: Не устанавливается pdns
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/pdns)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 10587
:
  Show dependency tree
 
Reported: 2006-10-15 13:45 by
Modified: 2007-04-21 16:20 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-15 13:45:54
Не устанавливается
$ rpmU pdns-2.9.20-alt1.i586.rpm
ошибка: неудовлетворенные зависимости:
        /usr/lib/libstdc++.so.6(CXXABI_1.3)   нужен для pdns-2.9.20-alt1
        /usr/lib/libstdc++.so.6(GLIBCXX_3.4)   нужен для pdns-2.9.20-alt1
------- Comment #1 From 2006-10-21 22:13:08 -------
На ALM24 команда "rpm -qp --requires pdns-2.9.20-alt1.i586.rpm | grep libstdc" 
выдаёт:
libstdc++.so.5
libstdc++.so.5(CXXABI_1.2)
libstdc++.so.5(GLIBCPP_3.2)
libstdc++.so.5(GLIBCPP_3.2.2)
Эти зависимости прописались при сборке автоматически.
В спеке есть только запись "BuildPreReq: libstdc++-devel".

Таким образом, либо в Сизифе проблема со свежими версиями libstdc,
либо libstdc просто не инсталлирована в системе.
------- Comment #2 From 2006-12-03 05:32:04 -------
Если новых комментариев не будет, багу предлагаю закрыть.
------- Comment #3 From 2006-12-05 08:34:24 -------
Ну вообще странно, текущий /usr/lib/libstdc++.so.6 провайдит и CXXABI_1.3 и
GLIBCXX_3.4.
------- Comment #4 From 2006-12-06 12:28:51 -------
Никто разницы не замечает??
$ rpm --provides libstdc++4.1
libstdc++ = 4.1.1-alt10
libstdc++3.4 = 4.1.1-alt10
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)

А pdns требует такую зависимость (с полным путём):
/usr/lib/libstdc++.so.6(GLIBCXX_3.4)

На Сизифе такая команда: $ rpm -qp --requires pdns-2.9.20-alt1.i586.rpm | grep 
libstdc выдаёт:
/usr/lib/libstdc++.so.6(CXXABI_1.3)
/usr/lib/libstdc++.so.6(GLIBCXX_3.4)
------- Comment #5 From 2007-01-04 17:22:42 -------
Fixed in 2.9.20-alt2, thanks to ldv (#10587).