Bug 10200 - libexo package contain file, which should be moved to devel package
: libexo package contain file, which should be moved to devel package
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libexo)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-28 19:13 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-28 19:13:13
Пакет libexo содержит файл /usr/lib/pkgconfig/exo-0.3.pc, который должен быть в
devel-пакете. Это приводит к тому, что при установке libexo цепляет за собой
кучу ненужных devel-пакетов.

Подробности см. тут: 
http://lists.altlinux.org/pipermail/sisyphus/2006-October/088273.html
http://lists.altlinux.org/pipermail/sisyphus/2006-October/088274.html
Steps to Reproduce:
1. apt-get instal libexo
2.
3.
------- Comment #1 From 2006-10-28 23:02:35 -------
Блин, не ту сборку залил в Сизиф :(
Завтра с утра отправлю правильную:)
------- Comment #2 From 2006-11-01 14:20:00 -------
[denis@ogion Салтан]$ apt-get install libexo
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libexo: Требует: python2.4(_exo) но пакет не может быть установлен
E: Извините, `битые' пакеты
------- Comment #3 From 2006-11-01 20:33:44 -------
Ааа!!! Это грабли rpm-build-compat,заботливо разложенные для желающих... Там
переопределяется %_libexecdir, а в инкаминге он совсем другой...
------- Comment #4 From 2006-11-01 20:42:52 -------
(In reply to comment #3)
> Ааа!!! Это грабли rpm-build-compat,заботливо разложенные для желающих... Там
> переопределяется %_libexecdir, а в инкаминге он совсем другой...

Блин... Ну и от куда бы узнал о этих граблям. :)
------- Comment #5 From 2006-11-01 21:07:01 -------
Сейчас прогоню все пакеты еще раз через сборку и изменившиеся с увеличенным
релизом перезалью...
------- Comment #6 From 2006-11-06 22:38:38 -------
Починил... Вместе с новой версией залил...
------- Comment #7 From 2006-11-09 16:10:47 -------
Теперь нормально обновилось. Так что закрываю.