Bug 10205 - Этот пакет надо адаптировать для xawtv4
: Этот пакет надо адаптировать для xawtv4
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xawtv4-vdr)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-29 19:54 by
Modified: 2008-03-18 10:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-29 19:54:19
Скрипт XawVDR следует заменить на:

#!/bin/sh
# start VDR in the daemon mode
runvdr -d

# find the SS1 video device
ss1viddev=0
for i in $(xawtv -hwconfig 2>&1 ); do
    if [ ! -z "$(echo $i | grep '"dvb":' )" ]; then ss1viddev=1
    fi
    if [ $ss1viddev -eq 1 ]; then
        if [ ! -z "$(echo $i | grep '/dev/video' )" ]; then 
            videodev=$i
            break
        fi
    fi
done

# start xawtv telling it to use the SS1 video device
if [ -c "$videodev" ]; then 
    xawtv -video "$videodev"
else 
    xawtv
fi

# stop vdr
killall vdr -9

Такой способ запуска возможен только на СС1, так как позволяет не загружать
процессор декодированием ТВ потока. На СС2 нужно задействоать программное
декодирование xawtv.


Кроме того, устанавливаемые этим пакетом файлы настроек должны заменять файлы
/etc/X11/*/app-defaults/Xawtv4. Иначе невозможно вызвать меню VDR.

Steps to Reproduce:
1.Установить
2.Увидеть что не работает

Actual Results:  
По нажатию пробела xawtv пытается переключиться на другой эфирный канал.

Expected Results:  
Должно появляться меню VDR
------- Comment #1 From 2006-11-10 11:21:32 -------
Скрипт XawVDR заменил.
------- Comment #2 From 2006-12-13 23:52:15 -------
Изменено