Bug 10339 - Should conflict libtotem
: Should conflict libtotem
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/libtotem-xine)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
: 10346
:
  Show dependency tree
 
Reported: 2006-11-29 02:04 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-11-29 02:04:30
Поскольку libtotem и libtotem-xine конфликтуют по файлам, хотя бы в одной из
них
нужно прописать конфликт на другую.
------- Comment #1 From 2006-11-29 12:30:18 -------
Ок, поскольку totem-xine это, так сказать, побочная ветка, то в ней и пропишем.
------- Comment #2 From 2006-11-29 13:11:54 -------
Попробовал, к сожалению в лоб не получилось. Для того, чтобы можно было ставить
libtotem-xine для программ, в которых явно прописано Requires libtotem (я
пользуюсь rhythmbox) я ставлю для libtotem-xine Provides: libtotem-%version.
Если сюда же добавить Conflicts: libtotem, то пакет оказывается конфликтующим
сам с собой (по крайней менре мне выдаётся сообщение: libtotem кофликтует с
libtotem-xine, хотя в системе стоит только libtotem-xine).
------- Comment #3 From 2006-11-30 00:41:00 -------
Ну что же, тогда стоит сделать так, как стоило сделать с самого начала:
libtotem-xine, libtotem-gstreamer, обе провайдят libtotem и конфликтуют друг с
другом. https://bugzilla.altlinux.org/show_bug.cgi?id=10346
------- Comment #4 From 2008-01-06 18:54:09 -------
Решение проблемы - в Bug 10346.
------- Comment #5 From 2008-04-20 17:01:01 -------
(In reply to comment #0)
> Поскольку libtotem и libtotem-xine конфликтуют по файлам, хотя бы в одной из них
> нужно прописать конфликт на другую.

Уже нет.