Bug 10366 - bad pkg-config file
: bad pkg-config file
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libsoundtouch)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
: 9677
:
  Show dependency tree
 
Reported: 2006-12-04 16:41 by
Modified: 2007-03-16 19:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-04 16:41:49
В исходном пакете идет вполне вменяемый soundtouch-1.0.pc файл, есть софт,
ищущий библиотеку именно по такому файлу... Я говорю об ardour... И есть софт,
авторы которого не удосужились разобраться что же им нужно для сборки своего
поделия, ибо по :

[eugene@mobile ~]$ apt-cache whatdepends libsoundtouch
libsoundtouch-1.3.1-alt0.3
  libsoundtouch-devel-1.3.1-alt0.3
    Требует: libsoundtouch = 1.3.1-alt0.3

библиотека никому не нужна... Может все-таки откатить этот безумный
дибиановский
патч и инсталировать нормальный .pc файл?
------- Comment #1 From 2006-12-06 11:57:08 -------
Вас не затруднит указать мне точнее где в исходном пакете лежит этот 
soundtouch-1.0.pc?
Я не могу найти.
------- Comment #2 From 2006-12-06 12:03:21 -------
В пакете с исходниками soundtouch-1.3.1.tar.gz, кстати а каково происхождение
soundtouch_v1.3.1.tar.bz2, который упакован в пакет? На сайте разработчиков
ничего подобного нет.
------- Comment #3 From 2006-12-07 02:31:22 -------
Кроме как с сайта ему вроде взяться было некому. Возможно в какой-то момент 
переименовали.
В общем, спасибо за подсказку, делаю новую сборку с правильным тарболом.

1.3.1-alt1