Bug 10401 - missing php5-gd2 dependency
: missing php5-gd2 dependency
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/zabbix-phpfrontend)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-12-12 00:32 by
Modified: 2007-04-10 10:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-12 00:32:16
У пакета отсутствует зависимость на php gd.
------- Comment #1 From 2006-12-12 09:02:44 -------
У пакета есть зависимость на php-gd2. А php5-gd2 не провайдит php-gd2. Т.о.
нужно делать два пакета phpfrontend, один с зависимостью на php-gd2, а другой
на
php5-gd2.
------- Comment #2 From 2006-12-13 08:32:36 -------
Вообще, это безобразие. Необходимо сделать так, чтобы и php-MODULE и
php5-MODULE
провайдили что-то общее, например php-module-MODULE.
------- Comment #3 From 2006-12-13 08:53:51 -------
Полностью согласен с последним комментарием.
------- Comment #4 From 2007-04-05 13:49:43 -------
До сих пор не понятно, что именно сделать с этой багой. Обсуждение в devel@ не
дало результатов.
http://lists.altlinux.org/pipermail/devel/2006-December/039517.html
------- Comment #5 From 2007-04-10 10:52:01 -------
В общем, в 1.1.7-alt1 я сделал так: файлы фронтенда вынесены в
phpfrontend-engine, а зависимости на php{5}-gd помещены в подпакеты
phpfrontend-php4 и phpfrontend-php5 соответственно.