Bug 10408 - нужна зависимость на bzip2
: нужна зависимость на bzip2
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-12-12 19:48 by
Modified: 2008-03-01 14:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-12 19:48:56
если не установлен bzip2, apt-get не работает с ftp/http источниками. поскольку
по факту он требует наличия bzip2, разумно будет внести в зависимости. 

(ЗЫ. заметить это могут немногие - если не стоит bzip2, то не стоит и man,
interactivesystem и еще много чего. я столкнулся в контейнере ovz)
Steps to Reproduce:
apt-get:

apt-get update

Get:1 ssh://gns.mirror i586 release [483B]

Fetched 483B in 0s (855B/s)

Get:1 ssh://gns.mirror i586/hasher pkglist [7188B]

Hit ssh://gns.mirror i586/hasher release

Err ssh://gns.mirror i586/hasher pkglist

Sub-process bzip2 returned an error code (100)

Fetched 7188B in 0s (9766B/s)

Failed to fetch
ssh://gns.mirror/home/public/sisyphus/gns/gns.mysql/i586/base/pkglist.hasher
Sub-process bzip2 returned an error code (100)

Reading Package Lists...

Building Dependency Tree...

E: Some index files failed to download, they have been ignored, or old ones
used
instead.
------- Comment #1 From 2007-03-24 01:17:24 -------
Fixed in 0.5.15lorg2-alt10