Bug 1049 - /etc/rc.d/init.d/sound не запускает миксер
: /etc/rc.d/init.d/sound не запускает миксер
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sound-scripts)
: unstable
: all Linux
: P1 critical
Assigned To:
:
:
:
:
: 3005
  Show dependency tree
 
Reported: 2002-07-03 17:16 by
Modified: 2005-08-30 03:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-07-03 17:16:42
если используется Alsa + прописанные в modules.conf драйвера Alsa. Рекомендую
поправить скрипт так, чтобы start_mixer запускался в любом случае.
---

---
------- Comment #1 From 2003-01-04 21:40:30 -------
надо просто вписать, чтобы запускался \"alsactl restore\" в Sxxsound
start и \"alsactl store\" в Kxxsound stop
В целом суть такова: если драйвера - alsa, то использовать alsactl, а если
драйвера - oss, то использовать aumix, или что-то подобное (aumix плох тем, что
тянет gtk за собой...).
Удачи!
------- Comment #2 From 2003-01-04 21:40:30 -------
надо просто вписать, чтобы запускался \"alsactl restore\" в Sxxsound
start и \"alsactl store\" в Kxxsound stop
В целом суть такова: если драйвера - alsa, то использовать alsactl, а если
драйвера - oss, то использовать aumix, или что-то подобное (aumix плох тем, что
тянет gtk за собой...).
Удачи!
------- Comment #3 From 2003-10-27 15:37:15 -------
*** Bug 1711 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2003-10-27 15:49:16 -------
Вообще говоря, было бы _крайне_ уместно решить проблему до финального
Compact-2.3.
------- Comment #5 From 2003-10-27 15:49:53 -------
(severity up)
------- Comment #6 From 2003-10-29 20:58:39 -------
кусок "как это сделано в мандраке":

сейчас эта мысль в моей обработке вместе с патчем из #1711 (alsactl
store/restore) допиливается для sound-scripts-0.2.

---

function start_mixer () {
    # ALSA
    if [ -d /proc/asound ] && [ -x /usr/sbin/alsactl ]; then
        # is ALSA already configured ?
	if [[ ! -r /etc/asound.state ]]; then
	    # provide decent default sound level for alsa drivers
	    if [ -d /proc/asound ] && [ -x /usr/sbin/alsactl ];then
             MIXER_SETTINGS=/root/tmp/asound.state_tmp
             alsactl -f $MIXER_SETTINGS store
        	   # set volume to 67%
             perl -pi -e 's/(value\w*\S*)\s* 0/\1 20/' $MIXER_SETTINGS
        	   # unmute all channels
             perl -pi -e 's/(value\w*\S*)\s* false/\1 true/' $MIXER_SETTINGS
             action "Setting mixer settings" alsactl -f $MIXER_SETTINGS restore
             rm -f $MIXER_SETTINGS
		return 0
	    fi
	    # if we've not alsa-utils, we'll fallback on OSS initialization below
	else
	    # Not first boot:
	    # Done by alsa service but only if sound service is not
	    # enabled (hance this code path).
	    # We'll merge in back aksa service once mdk9.2 is released.
	    # [but we'll still handle both aumix & alsactl in order
	    #  to manage packages removing / driver switch]
	    action "Loading mixer settings" /usr/sbin/alsactl restore
	    return 0
	fi
    fi
    # OSS
    if egrep -q '(sparcaudio|sound)' /proc/devices 2>/dev/null && \
	[ "$retval" -eq 0 ] && [ -x /usr/bin/aumix ];then
	if [ ! -r /etc/.aumixrc ];then
	    action "Setting mixer settings" /usr/bin/aumix -v80 -w80 -c80
	else
	    action "Loading mixer settings" /usr/bin/aumix -f /etc/.aumixrc -L
	fi
    fi
}

------- Comment #7 From 2004-01-11 19:20:33 -------
changed maintainer 
------- Comment #8 From 2004-01-13 18:42:53 -------
Fixed.