Bug 10602 - xfce4-session и xfce4-session-engines предлагается к сносу при dist-upgrade
: xfce4-session и xfce4-session-engines предлагается к сносу при dist-upgrade
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xfce4-session)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-07 09:50 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-01-07 09:50:59
Что-то уже с неделю наверно не могу провести до конца dist-upgrade,
т.к. он предлагает снести xfce4-session и xfce4-session-engines. Про
них забыли или что-то случилось на пути в Сизиф? Другие пакеты из xfce
обновить предлагает, а эти пытается снести.

[denis@ogion ~]$ apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
 Terminal Thunar dbus dbus-tools dbus-tools-gui gnome-vfs hal ipv6calc ivman
 libavahi libavahi-glib libavahi-qt3 libbonoboui libdaemon libdbus
 libdbus-glib libdbus-qt libgnomeprintui libhal libldap2.3 pmount powersave
 xfce-utils xfdesktop
Следующие пакеты будут УДАЛЕНЫ:
 xfce4-session xfce4-session-engines
Следующие пакеты будут СОХРАНЕНЫ:
 fpc
24 будет обновлено, 0 новых установлено, 2 пакетов будет удалено и 1
не будет обновлено.
Необходимо получить 9645kB архивов.
После распаковки будет освобождено 1752kB дискового пространства.
Продолжить? [Y/n] n
Прервано.

[denis@ogion ~]$ apt-get install xfce-utils xfdesktop xfce4-session
xfce4-session-engines libdbus
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия xfce4-session уже установлена.
Последняя версия xfce4-session-engines уже установлена.
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
 xfce4-session: Требует: libdbus-1.so.2
E: Извините, `битые' пакеты

Вывод: xfce4-session не пересобран с новым libdbus.

Steps to Reproduce:
1.apt-get update
2.apt-get dist-upgrade
3.
------- Comment #1 From 2007-02-26 04:34:32 -------
После обновления XFCE до 4.4 стало нормально.
------- Comment #2 From 2007-02-26 04:35:01 -------
Закрываю.