Bug 10799 - samba-common: %pre assumes samba package installed
: samba-common: %pre assumes samba package installed
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/samba-common)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-08 14:44 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-08 14:44:27
Preparing...                                 
###################################################################################################
[100%]
service: smb: Unrecognized service
service: smb: Unrecognized service
1: samba-common                              
###################################################################################################
[ 25%]

$ rpm -q --scripts samba-common | grep service
    smbstopped=$(/sbin/service smb status|grep stopped)
    wnbstopped=$(/sbin/service winbind status|grep stopped)
    [ -n "$smbstopped" ] || /sbin/service smb stop
    [ -n "$wnbstopped" ] || /sbin/service winbind stop
    /usr/sbin/post_service winbind
/usr/sbin/preun_service winbind

$ rpm -q samba
warning: package samba is not installed

---

Might make sense to [ -x /etc/init.d/smb ] first and if absent, skip any
attempted actions.  A patch sir? :)
------- Comment #1 From 2007-04-18 01:17:56 -------
my
------- Comment #2 From 2007-04-18 01:18:13 -------
Fixed in 3.0.24-alt2