Bug 10807 - postgresql не стартует
: postgresql не стартует
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/postgresql8.0-server)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-08 23:20 by
Modified: 2008-06-13 12:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-08 23:20:39
# /etc/init.d/postgresql start
Adjusting environment for postgresql:                                                      
[ DONE ]
Creating default database: /bin/su: unrecognized option 
`--pgdata=/var/lib/pgsql-root/var/lib/pgsql/data'
usage: su [-|-l] [-c "command"] [-s "shell"] [username]
                                                                                      
[FAILED]

опечаточка где-то?

[root@alt ~]# rpm -q postgresql8.0-server
postgresql8.0-server-8.0.11-alt1
------- Comment #1 From 2007-02-23 10:44:50 -------
Денис, проверь, плс.
------- Comment #2 From 2007-04-01 00:46:29 -------
Так а чего тут проверять то?

Бага есть и в 8.0 и в 8.1 и в 8.2 - покажу на примере

# ls -ld /var/lib/p*
ls: /var/lib/p*: No such file or directory
# rpm -qa |grep postgresql
# apt-get install postgresql8.1-server
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  postgresql-common postgresql8.1
The following NEW packages will be installed:
  postgresql-common postgresql8.1 postgresql8.1-server
0 upgraded, 3 newly installed, 0 removed and 0 not upgraded.
Need to get 0B/5571kB of archives.
After unpacking 14.5MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Committing changes...
Preparing...                 ####################################### [100%]
1: postgresql8.1             ####################################### [ 33%]
2: postgresql8.1-server      ####################################### [ 66%]
groupadd: group psqluser exists
Done.

# service postgresql start
Adjusting environment for postgresql:                               [ DONE ]
Creating default database: /bin/su: unrecognized option 
`--pgdata=/var/lib/pgsql-root/var/lib/pgsql/data'
usage: su [-|-l] [-c "command"] [-s "shell"] [username]
                                                                    [FAILED]


вот так вот :(
как я понимаю в /etc/init.d/postgresql не отрабатывает

action "Creating default database:" /bin/su -s /bin/sh -l po
stgres -c "/usr/bin/initdb --pgdata=\"$PG_CHROOT_DIR$PGDATA\""
------- Comment #3 From 2007-04-17 20:42:55 -------
postgresql8.2-server-8.2.3-alt4
------- Comment #4 From 2007-04-17 20:44:31 -------
*** Bug 11394 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2007-04-17 20:54:47 -------
*** Bug 11425 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2007-05-03 16:22:42 -------
# /usr/sbin/vzctl exec 105 service postgresql start
Adjusting environment for postgresql: [ DONE ]
Creating default database: /bin/su: unrecognized option
`--pgdata=/var/lib/pgsql-root/var/lib/pgsql/data'
usage: su [-|-l] [-c "command"] [-s "shell"] [username]
[FAILED]

# /usr/sbin/vzctl exec 105 rpm -qa | grep postgresql
postgresql8.1-8.1.8-alt3
postgresql8.1-server-8.1.8-alt3
postgresql-common-1.0-alt3
------- Comment #7 From 2007-05-03 22:04:25 -------
postgresql8.2 работает правильно?
------- Comment #8 From 2007-05-03 23:58:21 -------
юзайте 8.2 - там поправлено.
------- Comment #9 From 2007-05-12 19:48:30 -------
8.2.4-alt2 - ok
------- Comment #10 From 2007-05-12 19:49:07 -------
8.2.4-alt2 - ok