Bug 10834 - Пакет libglew-devel не содержит зависимости на libmesa-devel
: Пакет libglew-devel не содержит зависимости на libmesa-devel
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libglew)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-14 10:48 by
Modified: 2007-03-19 00:49 (History)


Attachments
Fix problem when using GLEW and GLUT together. (717 bytes, patch)
2007-02-15 01:11, serpiph
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-14 10:48:18
При использовании пакета libglew-devel для сборки программ возможна ситуация,
когда программа не соберётся по причине отсутствия у человека пакета
libmesa-devel, который предоставляет файлы GL/gl.h и GL/glu.h. Данные файлы
подключаются в файле GL/glew.h, поэтому и пакет libglew-devel должет содержать
зависимость на libmesa-devel. Для примера можно глянуть в enblend-3.0, который
со дня на день должен появиться в Сизифе.
Steps to Reproduce:
Сборка программ в hasher, если в пакете стоит зависимость на libglew-devel, но
нет зависимости на libmesa-devel.
Actual Results:  
Ошибка сборки.

Expected Results:  
Нормальная сборка
------- Comment #1 From 2007-02-14 17:50:35 -------
You're right.

Apparently, i've alreafy fixed it in my git repo.
------- Comment #2 From 2007-02-15 01:11:56 -------
Created an attachment (id=1800) [details]
Fix problem when using GLEW and GLUT together.
------- Comment #3 From 2007-02-19 16:11:42 -------
Fixed in glew-1.3.5-alt1, going to i/S
------- Comment #4 From 2007-02-27 14:00:27 -------
Закроете?