Bug 10874 - unsupported flac >= 1.1.3
: unsupported flac >= 1.1.3
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mpd)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-19 18:49 by
Modified: 2007-02-26 16:44 (History)


Attachments
mpd-0.12.1+flac-1.1.3.patch (23.65 KB, patch)
2007-02-19 18:50, led@altlinux.org
no flags Details | Diff
mpd-0.12.1+flac-1.1.3.patch2 (836 bytes, patch)
2007-02-19 18:50, led@altlinux.org
no flags Details | Diff
mpd-0.12.1-configure.patch (1.86 KB, patch)
2007-02-19 18:51, led@altlinux.org
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-19 18:49:34
Не собирается с новой libFLAC.so.8 (flac >= 1.1.3).
Предлагаю патчи, с которыми поддерживается сборка и со старым, и с новым FLAC 
API (желательно обновить mpd до 0.12.1, с 0.12.0 патчи не проверялись)
------- Comment #1 From 2007-02-19 18:50:02 -------
Created an attachment (id=1819) [details]
mpd-0.12.1+flac-1.1.3.patch
------- Comment #2 From 2007-02-19 18:50:33 -------
Created an attachment (id=1820) [details]
mpd-0.12.1+flac-1.1.3.patch2
------- Comment #3 From 2007-02-19 18:51:25 -------
Created an attachment (id=1821) [details]
mpd-0.12.1-configure.patch

Собственно, патчи
------- Comment #4 From 2007-02-21 11:38:03 -------
мгу дать nmu. надо ?
------- Comment #5 From 2007-02-21 14:08:54 -------
(In reply to comment #4)
> мгу дать nmu. надо ?

А почему сами не можете сделать? Там ничего особенного делать не нужно: 
формально обновить до 0.12.1 и добавить указанные патчи.

Но если возможности такой у вас нет - давайте NMU (только сообщите мне, плиз, 
когда уже можно будет заливать пакет)
------- Comment #6 From 2007-02-21 15:35:39 -------
потому, что есть человек, у которого пакет уже собран. и мы оба знаем, кто это
:)

nmu дал.
------- Comment #7 From 2007-02-26 16:44:33 -------
fixed in mpd-0.12.1-alt1 (NMU)