Bug 10921 - Missing obsoletes
: Missing obsoletes
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libcurl3)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-24 21:14 by
Modified: 2007-09-22 11:10 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-24 21:14:41
file /usr/lib/libcurl.so.3.0.0 from install of libcurl3-7.15.5-alt2 conflicts 
with file from package libcurl-7.15.5-alt1.1
------- Comment #1 From 2007-02-26 10:39:03 -------
Это как это вылезло ?
------- Comment #2 From 2007-02-26 21:43:26 -------
apt-get install libcurl3 на январский сизиф.
------- Comment #3 From 2007-02-27 11:15:22 -------
Проблема в том, что libcurl3 не обсолетит libcurl

Он собран только для обратной совместимости со старыми пакетами.

Старый libcurl должен быть заменён новой версией libcurl.

Т.е. - apt-get install libcurl3 - это не правильно. Нужно одновременно ставить
libcurl

Я могу в libcurl3 добавить зависимость на новый curl, тогда не будет вылезать
таких проблем.
------- Comment #4 From 2007-02-27 17:44:16 -------
(In reply to comment #3)
> Проблема в том, что libcurl3 не обсолетит libcurl
Он обсолетит libcurl <= 7.15.5-alt1.1, не?

> Т.е. - apt-get install libcurl3 - это не правильно. Нужно одновременно ставить
> libcurl
Я так и сделал.
Но файловых конфликтов в нормальном репозитории быть вообще не должно.
------- Comment #5 From 2007-02-27 17:49:35 -------
Ну не obsoletes, так conflicts поставить нужно.

В libreadline4.3 стоит:

Conflicts: libreadline < 5.0
------- Comment #6 From 2007-02-28 14:56:48 -------
Ага.. вот. conflicts - поставим.
------- Comment #7 From 2007-09-22 11:10:40 -------
fixed