Bug 10922 - Missed dependency to pinentry-(gtk|qt)
: Missed dependency to pinentry-(gtk|qt)
Status: NEW
: Sisyphus
(All bugs in Sisyphus/claws-mail-plugin-pgpcore)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 18791
  Show dependency tree
 
Reported: 2007-02-25 11:14 by
Modified: 2009-07-08 12:01 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-25 11:14:21
Для отправки подписанных писем для отображения диалога ввода пароля к ключу 
GnuPG требуются установленные в системе пакеты pinentry-gtk или pinenty-qt.
В случае их отсутствия claws-mail выдаёт сообщение об ошибке 
"Data signing failed, no results."
и 
sgpgme.c:468:using key for xxx@yyy.zzz
pgpmime.c:527:gpgme_op_sign_result error
в консоли при запуске с ключом --debug.

Steps to Reproduce:
1. # apt-get remove pinentry-qt pinentry-gtk
2. Попробовать отправить подписанное письмо.
------- Comment #1 From 2009-02-10 10:12:49 -------
https://bugzilla.altlinux.org/show_bug.cgi?id=18790 -- тоже самое, но для
thunderbird-enigmail...
------- Comment #2 From 2009-07-08 12:01:42 -------
Это не обязательно pinentry, подойдёт любой графический GPG-агент, например,
seahorse-agent. Честно говоря, не знаю, что с этим делать - нужна зависимость
на всё что умеет выставлять переменную GPG_AGENT_INFO :) Наверное, правильнее
всего придумать какой-то виртуальный Provides типа gpg-agent-gui, например...