Bug 10934 - unsupported flac >= 1.1.3
: unsupported flac >= 1.1.3
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/moc)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-26 14:20 by
Modified: 2007-06-27 15:23 (History)


Attachments
moc-2.4.1+flac-1.1.3.patch (8.89 KB, patch)
2007-02-26 14:22, led@altlinux.org
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-26 14:20:52
Не собирается с новой libFLAC.so.8 (flac >= 1.1.3).
Предлагаю патч, с которым поддерживается сборка и со старым, и с новым FLAC 
API.
------- Comment #1 From 2007-02-26 14:22:47 -------
Created an attachment (id=1831) [details]
moc-2.4.1+flac-1.1.3.patch

Собственно, патч
------- Comment #2 From 2007-02-26 15:42:03 -------
Кто автор этого патча ?
------- Comment #3 From 2007-02-26 15:50:19 -------
(In reply to comment #2)
> Кто автор этого патча ?

Насколько я знаю, это патч от разработчиков flac

------- Comment #4 From 2007-02-26 15:56:35 -------
А можно ссылку для апстрима ?
------- Comment #5 From 2007-02-26 16:02:28 -------
(In reply to comment #4)
Ссылку - врядли... разве что такую:
ftp://ftp.altlinux.ru/pub/people/thresh/moc-2.4.1+flac-1.1.3.patch.gz
Набор патчей предоставили thresh@'у разработчики flac (опять же - насколько мне 
известно), о чём он писал в рассылке.
------- Comment #6 From 2007-02-26 16:05:57 -------
(In reply to comment #5)

Хотя... я его немного "допилил" (этот патч)
------- Comment #7 From 2007-06-27 12:38:47 -------
fixed?

* Thu May 10 2007 Alexey Gladkov <legion@altlinux> 2.5.0-alt0.1
- New version (2.5.0-alpha1)
------- Comment #8 From 2007-06-27 13:32:49 -------
Уже исправил