Bug 10940 - unsupported flac >= 1.1.3
: unsupported flac >= 1.1.3
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gst-plugins-good)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-26 15:30 by
Modified: 2007-02-27 16:17 (History)


Attachments
gst-plugins-good-0.10.5+flac-1.1.3.patch (36.49 KB, patch)
2007-02-26 15:30, led@altlinux.org
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-26 15:30:23
Не собирается с новой libFLAC.so.8 (flac >= 1.1.3).
Предлагаю патч, с которым поддерживается сборка и со старым, и с новым FLAC 
API.
------- Comment #1 From 2007-02-26 15:30:59 -------
Created an attachment (id=1836) [details]
gst-plugins-good-0.10.5+flac-1.1.3.patch

Собственно, патч
------- Comment #2 From 2007-02-26 21:07:20 -------
Будет ли достаточно просто приложить патч и отправить на сборку пакет? Или
что-то ещё придётся сделать?
------- Comment #3 From 2007-02-26 21:11:57 -------
(In reply to comment #2)

Да, достаточно.

------- Comment #4 From 2007-02-26 21:24:55 -------
(In reply to comment #3)
> (In reply to comment #2)
> 
> Да, достаточно.

Тогда, я сейчас отправлю пакет на сборку.
------- Comment #5 From 2007-02-26 21:29:09 -------
Забыл спросить. Патч идти и апстримить?
------- Comment #6 From 2007-02-26 21:32:04 -------
(In reply to comment #5)
> Забыл спросить. Патч идти и апстримить?

Ну, желательно... потому как я сделал было для 0.10.4, а сегодня пришлось на 
0.10.5 его править, потому как не подходил:) Лучше пусть апстрим это делает в 
дальнейшем:)
------- Comment #7 From 2007-02-26 21:48:45 -------
(In reply to comment #6)
> (In reply to comment #5)
> > Забыл спросить. Патч идти и апстримить?
> 
> Ну, желательно... потому как я сделал было для 0.10.4, а сегодня пришлось на 
> 0.10.5 его править, потому как не подходил:) Лучше пусть апстрим это делает в 
> дальнейшем:)

Понял. Сейчас подпишусь на из devel@ и кину в них патчем.

p.s.: пакет улетел на сборку