Bug 10946 - Do NOT obsolete suspend
: Do NOT obsolete suspend
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/hibernate)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-27 11:43 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-27 11:43:46
$ sudo apt-get dist-upgrade 
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REPLACED:
  suspend (by hibernate)
The following NEW packages will be installed:
  hibernate hibernate-cleanup
0 upgraded, 2 newly installed, 1 replaced, 0 removed and 0 not upgraded.
Need to get 104kB of archives.
After unpacking 439kB disk space will be freed.



$ rpm -ql --changelog suspend
* Mon Feb 19 2007 Andriy Stepanov <stanv@altlinux.ru> 0.50.cvs20070216-alt2

- Cleanup, add 2 patches : comments to config file, and use console

* Mon Feb 19 2007 Andriy Stepanov <stanv.altlinux.ru> 0.50.cvs20070216-alt1

- First test build for Alt linux Sisyphus

/etc/suspend.conf
/usr/sbin/resume
/usr/sbin/s2both
/usr/sbin/s2disk
/usr/sbin/s2ram
/usr/sbin/swap-offset


$ rpm -qp --lastchange hibernate-1.94-alt8.i586.rpm 
* Mon Feb 19 2007 Valery Inozemtsev <shrek.altlinux.ru> 1.94-alt8

- rollback suspen2-userui to 0.6.4
$ rpm -qp --obsoletes hibernate-1.94-alt8.i586.rpm
suspend  
$ rpm -qlp hibernate-1.94-alt8.i586.rpm | grep s2   
[1]    18428 done       rpm -qlp hibernate-1.94-alt8.i586.rpm | 
       18429 exit 1     grep s2


Я пользуюсь /usr/sbin/s2* вместе с пакетом powersave, hibernate мне не нужен. 
По видимому этот obsoletes тянется из каменного века.
------- Comment #1 From 2007-02-27 11:54:53 -------
да, я это видел. исправлено в alt9