Bug 10967 - Do NOT obsolete firmware-ipw2200
: Do NOT obsolete firmware-ipw2200
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firmware-ipw2200-2.2)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-01 14:50 by
Modified: 2007-03-06 12:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-01 14:50:28
$ sudo apt-get dist-upgrade                                   
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REPLACED:
  firmware-ipw2200-3.0 (by firmware-ipw2200)
The following NEW packages will be installed:
  firmware-ipw2200
0 upgraded, 1 newly installed, 1 replaced, 0 removed and 0 not upgraded.
Need to get 0B/272kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n] 

$ sudo apt-get dist-upgrade                                   
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REPLACED:
  firmware-ipw2200 (by firmware-ipw2200-2.2)
The following NEW packages will be installed:
  firmware-ipw2200-2.2 firmware-ipw2200-3.0
0 upgraded, 2 newly installed, 1 replaced, 0 removed and 0 not upgraded.
Need to get 0B/454kB of archives.
After unpacking 380kB of additional disk space will be used.
Do you want to continue? [Y/n] 

$ sudo apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REMOVED:
  firmware-ipw2200-3.0 kernel-modules-ipw2200-std-smp#1.2.1-alt2.132626.4
0 upgraded, 0 newly installed, 2 removed and 0 not upgraded.
Need to get 0B of archives.
After unpacking 1201kB disk space will be freed.
Do you want to continue? [Y/n] 

WTF?

$ rpm -qp --obsoletes firmware-ipw2200-2.2_2.2-alt2_noarch.rpm 
firmware-ipw2200  
$ rpm -qp --obsoletes firmware-ipw2200_3.0-alt2_noarch.rpm 
firmware-ipw2200-3.0
------- Comment #1 From 2007-03-05 00:32:48 -------
пакета ipw2200-2.2 больше нет в сизифе