Bug 10984 - нерабочий скрипт control
: нерабочий скрипт control
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kqemu-common)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-02 15:41 by
Modified: 2007-03-02 20:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-02 15:41:42
при установке (в процессе точечного обновления сизифа с 20061228) наблюдаем 
следующее:

3: kqemu-common              
############################################################################### 
[ 37%]
/etc/control.d/facilities/kqemu: line 36: mountpoint: command not found
/root/tmp/rpm-tmp.6458: line 2: mountpoint: command not found
/etc/control.d/facilities/kqemu: line 36: mountpoint: command not found
4: 
kernel-modules-kqemu-std-s######################################################

это потому что после dist-upgrade

[root@gns ~ ]# rpm -qf /bin/mountpoint
SysVinit-2.86-alt1

[root@gns ~ ]# grep SysV /var/log/messages
Mar  2 10:34:11 gns apt-shell: SysVinit-0:2.86-alt1 installed
Mar  2 10:34:12 gns apt-shell: SysVinit-0:2.85-alt9 removed

видимо, следует поставить 
Require: SysVinit >= 2.86-alt1

или еще круче будет
Require: /bin/mountpoint
------- Comment #1 From 2007-03-02 20:32:15 -------
На самом деле оба предложенных варианта неверны - должно быть:

PreReq: SysVinit >= 2.86-alt1

Fixed in kqemu-common 1.3.0-alt0.2.pre11.