Bug 11162 - Отсутствует /usr/lib/pkgconfig/cgilib.pc
: Отсутствует /usr/lib/pkgconfig/cgilib.pc
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libcgi-devel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-20 18:49 by
Modified: 2012-04-04 14:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-20 18:49:49
Отсудствует /usr/lib/pkgconfig/cgilib.pc.
В связи с этим не получается собрать rrdtools
Лечится как:
cat <<E_O_F> /usr/lib/pkgconfig/cgilib.pc 
# sdl pkg-config source file

prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include

Name: cgilib
Description:  Simple CGI library
Version: 0.5
Requires:
Conflicts:
Libs: -Wl,-rpath,${exec_prefix}/lib -lcgi -lpthread
Cflags: -I${includedir}/cgilib -D_GNU_SOURCE=1 -D_REENTRANT
E_O_F
Steps to Reproduce:
1. pkg-config --list-all | grep cgi
------- Comment #1 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #2 From 2011-01-22 17:17:17 -------
Актуально для 4.0..5.1/p5 (0.5-alt2)-- в сизифе пакета уже нет.
Оно тебе ещё надо?
------- Comment #3 From 2012-04-03 16:53:07 -------
Не знаю, на сколько это важно, но такого файла нет и в той версии, что в
Сизифе.
------- Comment #4 From 2012-04-04 14:07:43 -------
(В ответ на комментарий №3)
> Не знаю, на сколько это важно, но такого файла нет и в той версии, что в
> Сизифе.
думаю, что не важно, раз в апстриме такого файла нет.
но и добавить такой файл тоже нет проблем :)
[#68387] DONE srpm=libcgi-1.0-alt3_12.src.rpm