Bug 11219 - Don't link with libaudio
: Don't link with libaudio
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libwine)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-26 17:42 by
Modified: 2007-09-20 02:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-26 17:42:03
Package NAS is obsolete, please remove libaudio-devel from BuildRequires.
------- Comment #1 From 2007-03-26 23:03:16 -------
его и не в BuildRequires :)
но возможно он подхватывается через libarts-devel - вот его, пожалуй, уберу.

[lav@server wine]$ sudo rpm -e libaudio-devel
ошибка: удаление этих пакетов нарушит зависимости:
        libaudio-devel нужен для libarts-devel-1.5.5-alt2
        libaudio-devel нужен для libqt3-devel-3.3.7-alt1
        libaudio-devel нужен для libqt4-devel-4.2.2-alt4

А насчёт libaudio - по-моему, рановато: :)
$ sudo rpm -e libaudio
ошибка: удаление этих пакетов нарушит зависимости:
        libaudio = 1.7b-alt1.1 нужен для libaudio-devel-1.7b-alt1.1
        libaudio = 1.7b-alt1.1 нужен для nas-utils-1.7b-alt1.1
        libaudio.so.2   нужен для libqt3-3.3.7-alt1
        libaudio.so.2   нужен для nas-utils-1.7b-alt1.1
        libaudio.so.2   нужен для kpacman-0.3.2-alt7
        libaudio.so.2   нужен для TiMidity++-2.13.2-alt3
        libaudio.so.2   нужен для libarts-1.5.5-alt2
        libaudio.so.2   нужен для xlockmore-5.22-alt1
        libaudio.so.2   нужен для openoffice.org-2.1.0-alt3
        libaudio.so.2   нужен для libqt4-gui-4.2.2-alt4
        libaudio.so.2   нужен для mplayer-1.0-alt35.22020.1
        libaudio.so.2   нужен для libwine-20070304-alt1
------- Comment #2 From 2007-03-27 12:53:21 -------
(In reply to comment #1)
> его и не в BuildRequires :)
> но возможно он подхватывается через libarts-devel - вот его, пожалуй, уберу.

Не спеши. Предлагаю подождать пока от arts оторвут libaudio и тогда смотреть ещё
раз.
------- Comment #3 From 2007-03-27 23:37:53 -------
Ну чего я буду ждать - скоро и arts выкинут...
------- Comment #4 From 2007-03-28 02:59:17 -------
(In reply to comment #3)
> Ну чего я буду ждать - скоро и arts выкинут...

Ну... к тому моменту как ты проснёшся, можно уже будет вкидывать. :) Просто так.
Подняв релиз. Из libarts-devel уже дожны ьыли вынести зависимость на libaudio-devel.
------- Comment #5 From 2007-07-06 00:22:46 -------
Насколько я понял, ни libarts-devel, ни libaudio-devel уже не требуются при 
сборке wine.