Bug 11258 - insufficient package dependencies
: insufficient package dependencies
Status: CLOSED DUPLICATE of bug 5564
: Sisyphus
(All bugs in Sisyphus/console-data)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-29 04:01 by
Modified: 2010-10-30 12:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-29 04:01:43
$ hsh --without-stuff --ini --pkg-build=,
$ hsh-install console-common-scripts
Preparing packages for installation...
libreadline-5.1.4-alt2
bash-3.1.17-alt2
chkconfig-1.3.29-alt1
console-vt-tools-1.12-alt3
gzip-1.3.5-alt3
mktemp-1.5-alt2
findutils-4.2.29-alt1
libpcre3-7.0-alt2
grep-2.5.1a-alt2
sed-4.1.5-alt1
gzip-utils-1.3.5-alt3
kbd-1.12-alt3
msulogin-0.9.1-alt2
SysVinit-2.86-alt1
psmisc-22.3-alt1
termutils-5.6-alt1
service-0.5.13-alt1
glibc-locales-2.5-alt4
console-data-1999.08.29-alt3.2
service: keytable: Unrecognized service
console-common-scripts-0.2.2-alt1.3

Looks like console-common-scripts should depend on service.
------- Comment #1 From 2007-03-29 10:25:03 -------
#9008 #5564 - правда пакет стал несколько другой, но баги все остались.
------- Comment #2 From 2007-04-13 16:55:41 -------
]$ rpm -q --requires console-common-scripts|grep service
/usr/sbin/post_service  
/usr/sbin/preun_service

-- из spec
Requires(post): %post_service
Requires(preun): %preun_service
--

Или нужно требовать именно service?

------- Comment #3 From 2007-04-13 16:59:20 -------
У пакета console-data есть %post, которому нужен /etc/init.d/keytable
------- Comment #4 From 2007-09-19 13:31:00 -------
Думаю, что это моя бага.
------- Comment #5 From 2010-10-30 12:22:54 -------
Вторая бага про console-data, которому нужен service (и который уже заменён
kbd).

*** This bug has been marked as a duplicate of bug 5564 ***