Bug 11328 - move encodings to a separate package
: move encodings to a separate package
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xorg-x11-font-utils)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-03 14:36 by
Modified: 2007-04-06 15:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-03 14:36:54
В настоящее время в пакете xorg-x11-font-utils объединены два компонента xorg:

1) font-util-1.0.1 - утилиты для работы со шрифтами в формате BDF (bdftruncate,
ucs2any);

2) encodings-1.0.2 - файлы с описанием различных кодировок, используемые
libfontenc.

Предлагается выделить encodings в отдельный пакет (xorg-x11-font-encodings?).
Основания для этого следующие:

1) Пакет encodings может быть noarch (в нём будут только файлы из
/usr/share/X11/fonts/encodings - это текстовые файлы, сжатые gzip). Сейчас эти
данные дублируются по архитектурам из-за того, что лежат в одном пакете с
бинарником /usr/bin/ucs2any.

2) Данные из encodings могут быть использованы независимо от font-util -
например, luit пользуется libfontenc для перекодировки как минимум при
использовании кодировки dec-special (это alternate character set с символами
псевдографики, используемыми, например, в ncurses, mc, ...). Ставить в luit
зависимость на xorg-x11-font-utils неудобно из-за наличия в этом пакете
зависимостей на bdftopcf, mkfontdir, mkfontscale, которые для работы luit
совсем
не нужны.
------- Comment #1 From 2007-04-03 22:43:59 -------
вот xorg-x11-font-encodings-1.0.2-alt1 xorg-x11-font-utils-1.0.1-alt5