Bug 11403 - Использует gtk+
: Использует gtk+
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libstroke)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-07 01:43 by
Modified: 2008-06-06 01:38 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-07 01:43:10
Предлагаю собрать без поддержки gtk, раз уж gtk2 не поддерживает.
------- Comment #1 From 2007-04-07 01:53:04 -------
Эта старая библиотека, скорее всего, не соберётся с gtk2 без дополнительных
усилий.  Не думаю, что у меня в обозримом будущем появится возможность этим
заняться.
------- Comment #2 From 2007-04-07 10:33:20 -------
Так вот я думаю, что может быть просто собрать без gtk, не будет libgstroke, 
ну и ладно. Она и не используется:
$ apt-cache whatdepends libstroke
libstroke-0.5.1-alt7
  libstroke-devel-0.5.1-alt7
    Требует: libstroke = 0.5.1-alt7
  geda-gschem-20070216-alt1
  fvwm-base-2.5.18-alt2
    Требует: <libstroke.so.0>
      libstroke-0.5.1-alt7
------- Comment #3 From 2007-04-07 14:12:57 -------
Реализовать %def_disable gtk?
------- Comment #4 From 2007-04-08 15:30:23 -------
Я бы не надеялся, что gstroke будет нужна когда-либо, но если уж в идеале, то 
да, def_disable...
------- Comment #5 From 2008-05-31 11:37:20 -------
Я конечно не знаю насколько libstroke ещё продолжит существование...
7 лет релизов не было... Нужна она одному пакету... Но я бы собрал с ней geda, 
если бы она не тянула gtk+.
Может быть мне патч сделать?

$ apt-cache whatdepends libstroke
libstroke-0.5.1-alt7
  libstroke-devel-0.5.1-alt7
    Требует: libstroke = 0.5.1-alt7
  fvwm-base-2.5.23-alt1
    Требует: <libstroke.so.0>
      libstroke-0.5.1-alt7
------- Comment #6 From 2008-06-04 02:41:45 -------
(In reply to comment #3)
> Реализовать %def_disable gtk?

implemented in 0.5.1-alt8