Bug 11532 - 0413-install to mbr but i choosed install to parititon
: 0413-install to mbr but i choosed install to parititon
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/alterator-install2)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-17 14:32 by
Modified: 2007-11-10 14:46 (History)


Attachments
lilo.conf for 11532 (859 bytes, application/octet-stream)
2007-04-18 07:46, Mike Lykov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-17 14:32:04
беру server-0413
устанавливаю на компьютер, где уже есть sda1 (windows), добавляю sda2 (/), sda3
(/home)

все отлично разбивается, пакеты ставятся, переходит к этапу установки загрузчика.
выбираю "показать разделы", выбираю sda2, дальше, все ставится... перезагрузка..

видим текстовый интерфейс lilo (т.е. он поставился в mbr)
к чести сказать, windows нашел и прописал ее в загрузку автоматом, и она грузится.

Но я выбирал его на sda2 .. :)
------- Comment #1 From 2007-04-17 14:37:09 -------
Можно увидеть /etc/lilo.conf ?
------- Comment #2 From 2007-04-18 07:46:24 -------
Created an attachment (id=1908) [details]
lilo.conf for 11532
------- Comment #3 From 2007-04-18 10:24:20 -------
(In reply to comment #2)
> Created an attachment (id=1908) [edit] [details]
> lilo.conf for 11532

Вы меня извините, но в boot= прописан раздел. У устройств дисков не может быть
UUID. Тогда уж это бага в lilo.
------- Comment #4 From 2007-04-18 10:37:45 -------
(In reply to comment #0)
> видим текстовый интерфейс lilo (т.е. он поставился в mbr)
> к чести сказать, windows нашел и прописал ее в загрузку автоматом, и она грузится.
Это как "нашёл"?  Ставя свой MBR?  И если винда переписала MBR -- то LILO был с
честью переселён в межблинное пространство и грузится оттудова?

То ли утро, то ли как-то подробнее надо.
------- Comment #5 From 2007-04-18 10:55:12 -------
(In reply to comment #4)
> Это как "нашёл"?  Ставя свой MBR?  И если винда переписала MBR -- то LILO был 

Это как раз понятно. Модуль ищет разделы с определённым типом, отбирает из них
активные разделы и ищет на них признаки загрузчика. Если находит, то прописывает
секцию в lilo.conf.
------- Comment #6 From 2007-04-18 19:54:35 -------
(In reply to comment #3)
> (In reply to comment #2)
> > Created an attachment (id=1908) [edit] [details] [edit]
> > lilo.conf for 11532
> 
> Вы меня извините, но в boot= прописан раздел. У устройств дисков не может быть
> UUID. Тогда уж это бага в lilo.
> 

я вижу, что boot=UUID-что-то там. почему бы у раздела sda2 (тип - простой linux,
фс - ext3) не быть uuid ?

главное, что я хотел бы - это что если я выбираю "поставит загрузчик на раздел
sda2" - загрузчик из mbr не пропадал, не переписывался и не трогался.
А то неожиданность ;)

to mike@
винда была поставлена первой, поэтому она "ставила свой mbr" до этих событий и
ничего не переписывала ;)



------- Comment #7 From 2007-04-18 20:11:37 -------
(In reply to comment #6)
> я вижу, что boot=UUID-что-то там. почему бы у раздела sda2 (тип - простой linux,
> фс - ext3) не быть uuid ?

Вы не поняли :)
Как раз по этому признаку я и понял что это раздел. lilo.conf был создан
правильный. Далее дело за lilo ... это оно безобразничает.

Вы точно не запускали lilo после установки, может использовали какой-нибудь
модуль для донасройки ?
------- Comment #8 From 2007-04-18 20:29:18 -------
ааа. ну да. вроде правильный. только кто его ставит? (не туда)

нет, я ничего не запускал, через веб-морду не заходил, графики там нет, конфиг
не правил, lilo не запускал. так есть сразу после установки.

может, у кого воспроизведется? было бы проще
------- Comment #9 From 2007-04-18 20:41:05 -------
(In reply to comment #8)
> ааа. ну да. вроде правильный. только кто его ставит? (не туда)

Инсталятор запускает lilo всего два раза.
1) lilo -t -H -C "$lilo_conf_new" </dev/null 2>&1 >/dev/null
2) lilo -H </dev/null >/dev/null 2>&1

Первый это тест, второй это собственно установка (она делается после перемещения
lilo.conf в /etc).

> может, у кого воспроизведется? было бы проще

В том-то и дело что я несколько раз пробовал и у меня не получилось
воспроизвести эту ошибку.
------- Comment #10 From 2007-04-18 21:53:27 -------
это ж форменный цирк, товарищи ;)

итак, решил и я воспроизвести "эту ошибку".
на другом компьютере.
тут система такая: загрузчик windows в mbr.
разделы разбиты:
sda1, sda2  - windows, primary
sda4 - extended, в нем - sda5 пустой.

я создаю из инсталлера - sda6 под /, sda7 под /home

внимательнейше выбираю установить lilo в sda6
дальше, дальше.. перегружаюсь.. и вместо загрузчика получаю черный экран и
мигающий курсор. ни windows, ни lilo.

загружаюсь с windows rescue. восстанавливаю загрузчик windows в mbr.
ничего - курсор.
загружаюсь с altlinux rescue. вижу некоторые странности, о которых в другой баге ;)
загружаюсь с opensuse 10.2 rescue. делаю fdisk -l /dev/sda

и вижу - признак АКТИВНОСТИ (windows выбирает этот раздел, чтобы искать свой
загрузчик) - на .... SDA4

конечно, никакого загрузчика на sda4 НЕТ
исправляю - ставлю активность на sda1

VOILA!!!
windows успешно грузится.

внимание, вопрос - какого .. Рожна кто переставил туда признак активности?? ;))
------- Comment #11 From 2007-04-18 22:54:30 -------
при этом судя по dd if=/dev/sda6 ....
lilo там есть
------- Comment #12 From 2007-04-18 23:12:32 -------
(In reply to comment #10)
> это ж форменный цирк, товарищи ;)

смотря что называть цирком.

> тут система такая: загрузчик windows в mbr.
> разделы разбиты:
> sda1, sda2  - windows, primary
> sda4 - extended, в нем - sda5 пустой.

Вот это уже что-то для того чтобы воспроизвести.

> мигающий курсор. ни windows, ни lilo.

Тут всё понятно и предсказуемо.

> конечно, никакого загрузчика на sda4 НЕТ

для того чтобы быть уверенным стоит сказать detectloader.

> внимание, вопрос - какого .. Рожна кто переставил туда признак активности?? 

bootable флаг переставил инсталлятор. Мне только остаётся сосляться на #11391.
------- Comment #13 From 2007-04-18 23:13:55 -------
(In reply to comment #11)
> при этом судя по dd if=/dev/sda6 ....
> lilo там есть

Вы же понимаете что чудес не бывает.
------- Comment #14 From 2007-04-19 17:28:24 -------
(In reply to comment #12)
> (In reply to comment #10)
> > это ж форменный цирк, товарищи ;)
> смотря что называть цирком.

это я просто был немного поражен борьбой с граблями, взявшимися неожиданно откуда.


> Вот это уже что-то для того чтобы воспроизвести.
> > мигающий курсор. ни windows, ни lilo.
> Тут всё понятно и предсказуемо.

может, это специальная фича такая серверного варианта, который не рассчитан на
установку "в раздел" и соседство с другими ОС. Скажите это прямо, и багу можно
будет закрыть.
Но для меня это было непредсказуемо.
см. комментарий в #11391

> > конечно, никакого загрузчика на sda4 НЕТ
> для того чтобы быть уверенным стоит сказать detectloader.

он тогда сказал (я записал ;)
no bootloader on mbr, trying partitions
disk /dev/dm-3 doesn't contain valid partition table

> > внимание, вопрос - какого .. Рожна кто переставил туда признак активности?? 
> bootable флаг переставил инсталлятор. Мне только остаётся сосляться на #11391.

но почему он переставил его на sda4, хотя lilo оказался на sda6 ?
Напишите где-нибудь - "не предназначен для установки рядом с уже установленными
ОС".. ;)
------- Comment #15 From 2007-11-10 14:45:59 -------
Тёзка, предлагаю проверять уже на 4.0+ ;)