Bug 11616 - Не нормальный старт jed'а
: Не нормальный старт jed'а
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libslang)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-24 22:50 by
Modified: 2009-05-13 01:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-24 22:50:04
При установке libslang-1.4.9-alt1.0 и jed-0.99.18-alt1 во время запуска jed'а
наблюдается сообщение о неверном токене, что приводит к прерыванию парсинга
site.slc и некорректной загрузке редактора.

Удаление site.slc временно решает проблему, однамо, прекомиплляция site.slc все
равно не возможна:
[root@yarilo lib]# jed -batch -n -l preparse
loading /usr/share/jed/lib/site.sl
loading /usr/share/jed/lib/os.sl
loading /usr/share/jed/lib/menus.sl
loading /etc/jed.conf
loading /usr/share/jed/lib/compress.sl
loading /usr/share/jed/lib/preparse.sl
loading /usr/share/jed/lib/bytecomp.sl
loading /usr/share/jed/lib/site.sl
S-Lang Error: Type Mismatch: Unable to typecast String_Type to Integer_Type
S-Lang Error: Type Mismatch: called from line 270, file:
/usr/share/jed/lib/site.sl
S-Lang Error: Type Mismatch: Error processing /usr/share/jed/lib/site.sl
S-Lang Traceback: byte_compile_file
S-Lang Traceback: jed_byte_compile_file
File: /usr/share/jed/lib/bytecomp.sl
  Local Variables:
        $0: Type: String_Type,  Value:  "site.sl"
        $1: Type: String_Type,  Value:  "/usr/share/jed/lib/site.sl"
S-Lang Traceback: loop
S-Lang Error: Type Mismatch: called from line 151, file:
/usr/share/jed/lib/bytecomp.sl
S-Lang Traceback: evalfile
S-Lang Error: Type Mismatch: called from line 2, file:
/usr/share/jed/lib/preparse.sl
S-Lang Traceback: evalfile
S-Lang Traceback: while
S-Lang Traceback: command_line_hook
File: /usr/share/jed/lib/site.sl
  Local Variables:
        $0: Type: Integer_Type, Value:  1
        $1: Type: Integer_Type, Value:  4
        $2: Type: String_Type,  Value:  "-l"
        $3: Type: Undefined_Type,       Value:  Undefined_Type
        $4: Type: String_Type,  Value:  "preparse"
        $5: Type: Undefined_Type,       Value:  Undefined_Type
        $6: Type: Null_Type,    Value:  NULL
        $7: Type: String_Type,  Value:  "preparse"
S-Lang Error: Type Mismatch: Error while executing command_line_hook

Консультации с автором slang/jed показали, что проблема в использовании в
sl-файлах синтаксических конструкций, поддерживаемых только в slang-2.

Таким образом, оказывается, что пакеты libslang и jed рассингронизированы с
точки зрения версий.

Предлагается обновить libslang до версии 2.x
------- Comment #1 From 2007-04-25 02:08:19 -------
В процессе. Обновим в блажайшее время
------- Comment #2 From 2007-04-25 12:24:26 -------
*** Bug 11615 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2007-04-25 21:29:41 -------
Кстати, к сожалению придется держать обе версии библиотеки. mc, например
выглядит ужасно с libslang2

интересующиеся см.
https://bugzilla.altlinux.org/show_bug.cgi?id=10591
------- Comment #4 From 2009-05-13 01:18:31 -------
По-моему исправлено?