Bug 11650 - Dependency on libdbus-devel?
: Dependency on libdbus-devel?
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-dbus)
: unstable
: all Linux
: P3 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-29 00:13 by
Modified: 2007-09-12 17:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-29 00:13:03
В новой версии пакета наблюдается зависимость от libdbus-devel. Скорее всего,
она излишняя. Иначе стоит распилить пакет на часть для пользователей и часть
для
разработчиков.
------- Comment #1 From 2007-04-29 14:57:48 -------
Я проверю.
------- Comment #2 From 2007-04-29 15:28:47 -------
[icesik@iceberg RPM]$ rpm -qp --requires python-module-dbus-0.80.1-alt1.i586.rpm
python = 2.4
rpmlib(VersionedDependencies) <= 3.0.3-1
dbus
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.4)
libdbus-1.so.3
libdbus-glib-1.so.2
libglib-2.0.so.0
pkgconfig(dbus-1)
python2.4(__future__)
python2.4(inspect)
python2.4(logging)
python2.4(operator)
python2.4(os)
python2.4(traceback)
python2.4(warnings)
python2.4(weakref)
python2.4(xml)
rtld(GNU_HASH)
[icesik@iceberg RPM]$ rpm -Kv python-module-dbus-0.80.1-alt1.i586.rpm
python-module-dbus-0.80.1-alt1.i586.rpm:
MD5 sum OK: 88ea56e9b756dd6c88a4024aff43c14a
gpg: WARNING: unsafe ownership on homedir `/usr/lib/alt-gpgkeys'
gpg: Signature made Thu Apr 26 16:18:06 2007 EEST using DSA key ID 80EF7625
gpg: Good signature from "ALT Security Team (for packages) <security@altlinux.com>"
gpg:                 aka "ALT Security Team (for packages) <security@altlinux.org>"
gpg:                 aka "ALT Security Team (for packages) <security@altlinux.ru>"
[icesik@iceberg RPM]$

Не вижу зависимости.
------- Comment #3 From 2007-04-29 17:25:22 -------
(In reply to comment #2)
> pkgconfig(dbus-1)
А это что?
------- Comment #4 From 2007-08-28 00:33:31 -------
fixed in python-module-dbus-0.82.2-alt1