Bug 11869 - swatch dont run
: swatch dont run
Status: CLOSED DUPLICATE of bug 12101
: Sisyphus
(All bugs in Sisyphus/swatch)
: unstable
: all Linux
: P1 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-05-22 17:12 by
Modified: 2008-03-10 02:00 (History)


Attachments
patch (412 bytes, patch)
2007-09-26 17:21, Timur Batyrshin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-05-22 17:12:50
I use altlinux 4.0
i had install swatch via apt utils.
but when i issue swatch command 
i get error "Undefined argument in option spec"
 

Steps to Reproduce:
1.apt-get insatll swatch
2.swatch --help
3.Undefined argument in option spec
Actual Results:  
programm dont run!

Expected Results:  
Must be execute!
------- Comment #1 From 2007-06-06 18:57:01 -------
ALTLinux 4.0 Server
Не работает swatch!
------- Comment #2 From 2007-09-26 16:49:26 -------
Боюсь, Игорь уже не починит этот пакет.  Не хотите исправить?  Постараюсь
помочь.
------- Comment #3 From 2007-09-26 17:21:12 -------
Created an attachment (id=2210) [details]
patch

Теперь запускается.
Не проверял пока насколько хорошо/правильно работает в целом.
------- Comment #4 From 2007-09-26 17:30:04 -------
(In reply to comment #3)
> Created an attachment (id=2210) [edit] [details]
> patch
> 
> Теперь запускается.
> Не проверял пока насколько хорошо/правильно работает в целом.

Если кому отладка нужна будет и опция debug_level, которую я оторвал --
поправьте соответствующую строчку как надо - с синтаксисом перловской функции
GetOptions я разбираться не стал.
------- Comment #5 From 2008-02-15 20:01:21 -------
should be fixed by now:
* Fri Jun 22 2007 Slava Semushin <php-coder@altlinux> 3.2.1-alt1
- NMU
- Updated to 3.2.1 (also should fix #12101)
- Use macros from perl-devel package for building and installation
- Exclude COPYING and COPYRIGHT files from package
- Spec cleanup:
  + Replaced tabs to one space
  + Updated Url tag
  + Set Packager tag to previous maintainer
  + Updated url in Source tag
  + Updated BuildRequires
  + Don't use %name macros in %description
  + s|%setup -q -n %name-%version|%setup|
  + s|%_mandir|man1/%_man1dir|

is it reasonable to issue a backport/update? (moving to sisyphus)
------- Comment #6 From 2008-02-16 11:58:51 -------
(In reply to comment #5)
> should be fixed by now:

Это надо проверить.

Кстати, уже с год как есть новая версия, но я не стал её собирать, т.к. думал, 
что программой никто не пользуется. Могу собрать как будет время.
------- Comment #7 From 2008-02-16 11:59:57 -------
re
------- Comment #8 From 2008-02-16 12:00:25 -------
Вот и желающий нашёлся :)

-> php-coder
------- Comment #9 From 2008-02-16 16:29:33 -------
Вообще если сам не пользуешься -- закрой и забудь.  Будет кому надо --
озадачатся _и это будет лучше_.

А то внезапно оказывается, что по уши в разваливающемся при каждом чихе
барахле,
о цели существования которого даже не догадываешься. :)  И на то, что
интересно,
уже не хватает здоровья.
------- Comment #10 From 2008-03-09 23:18:39 -------
Сухой итог следующий: я поставил swatch из Сизифа и запустил с опцией --help.
Он
мне выдал что надо. Я посмотрел на bug #12101 и увидел, что в баге говорится о
в
точности таких же симптомах, как и здесь. При этом noc@ не указал версии
swatch...

Короче, на 90% это исправлено в той версии, что есть в Сизифе (и согласно
sisyphus.ru в бранче). Новую версию я собирать не буду, так как не вижу особой
на то необходимости да и желания у меня не много, т.к. не использую эту
программу.



*** This bug has been marked as a duplicate of 12101 ***
------- Comment #11 From 2008-03-10 02:00:46 -------
P.S. Только что отправил 3.2.2 в Сизиф...