Bug 12055 - Не получается подключить python к БД
: Не получается подключить python к БД
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/postgresql8.2-python)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-06-17 23:47 by
Modified: 2007-12-31 20:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-06-17 23:47:13
# createdb -U postgres test
CREATE DATABASE
# createlang -U postgres plpgsql test
# createlang -U postgres plpython test
createlang: language installation failed: ERROR:  unsupported language "plpython"
HINT:  The supported languages are listed in the pg_pltemplate system catalog.
# ls /usr/lib64/pgsql/pl*.so
/usr/lib64/pgsql/plpgsql.so  /usr/lib64/pgsql/plpython.so
# psql -U postgres 
postgres=# select * from pg_pltemplate;
 tmplname  | tmpltrusted |      tmplhandler      |   tmplvalidator   |  
tmpllibrary    | tmplacl 
-----------+-------------+-----------------------+-------------------+------------------+---------
 plpgsql   | t           | plpgsql_call_handler  | plpgsql_validator |
$libdir/plpgsql  | 
 pltcl     | t           | pltcl_call_handler    |                   |
$libdir/pltcl    | 
 pltclu    | f           | pltclu_call_handler   |                   |
$libdir/pltcl    | 
 plperl    | t           | plperl_call_handler   | plperl_validator  |
$libdir/plperl   | 
 plperlu   | f           | plperl_call_handler   | plperl_validator  |
$libdir/plperl   | 
 plpythonu | f           | plpython_call_handler |                   |
$libdir/plpython | 

Почему я не могу подключить python к БД?
------- Comment #1 From 2007-06-18 04:45:18 -------
Наверное потому что бд работает в чруте а в чруте питона нету.
Нужно копировать питон в чрут, а в каком объеме не понятно.
------- Comment #2 From 2007-06-18 07:49:52 -------
Да, посыпаю голову пеплом, в чруте питона действительно нету, а появляется он
там только после update_chroot lib. А то, что после удаления
postgresql8.2-python его надо руками удалять из чрута - это нормально?
------- Comment #3 From 2007-06-18 07:50:33 -------
*** Bug 12056 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2007-06-18 07:50:42 -------
*** Bug 12057 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2007-06-18 08:38:48 -------
Это, видимо, не нормально. И на это надо вешать отдельный баг.
------- Comment #6 From 2007-12-31 20:13:36 -------
закрываю